Support » Fixing WordPress » image upload not generating alternate image sizes

  • When I upload an image, it is available in the original size only. No alternate sizes are created/available within WordPress or in the file system. No error messages are given.

    Troubleshooting Info: Working in an up-to-date plain vanilla install of WordPress 3.5.1, using the default theme with no plugins and media sizes are set at the defaults (150/150, 300/300, 1024/1024), on a server running Ubuntu 12.4.2 LTS, with the GD graphics library installed.

    All other WordPress functions are working fine. Inserting images works fine, it just offers only the original size image, labeled “full size.”

    After initial testing, I then installed two image regeneration plugins: Regenerate Thumbnails, Simple Image Sizes. When I ran them without changing the default image size settings, they ran and announced completion/success but did not create any alternate image files. (Each image is still in its original uploaded size.)

    Speculation: It is as if the alternate size information is not available to any image manipulation tool, either built-in or plugin.

Viewing 3 replies - 1 through 3 (of 3 total)
  • …additionally, I had previously done the troubleshooting checklist and tried all suggestions in this closed thread:

    It seems that this issue is not uncommon but the usual culprit is a plugin or theme that is meddling with the upload process. But as your installation is vanilla, this doesn’t apply.

    Here are a few thoughts:

    Do the alternate size files get created in the file system but just not show up in the admin?

    Are you uploading particularly large files, have you tried different files & filetypes as well?

    Have you tried enabling debug (in wp-config) and then checking error log files?
    I’m guessing you’ve tried a new installation of WP too.


    I had the same problem until I installed php5-gd package. Just double check if you have it installed.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘image upload not generating alternate image sizes’ is closed to new replies.