Support » Plugin: Safe SVG » Image upload not allowed after WP update

  • Resolved amirdbest


    Hi there, After updating my WordPress site I am not able to upload SVG images anymore. Previously uploaded images are working fine.
    When I try to upload an SVG image I get the WordPress error “Sorry, you are not allowed to upload this file type”.

    I tested other SVG plugins and they seem to fix the issue! however they are not optimal for me and I need this plugin!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Darin Kotter


    @amirdbest Thanks for the report. I’ve tried to reproduce in a couple environments that are running WP 6.0 but I’ve not yet had any issues. So a couple questions to try and help narrow this down.

    Which version of Safe SVG are you running?
    How are you uploading images? Straight into the media library? Using an Image block within a post? Using the classic editor on a post? Some other approach?

    Thread Starter amirdbest


    I am using Version 2.4.2. I am not able to upload from any place. I tried different parts of WordPress and I get the same message.

    It may be due to the “Wordfence” plugin. However some plugin settings are active upon plugin deactivation and I don’t want to touch the settings.

    Plugin Support Darin Kotter


    I’m not familiar with WordFence but it may be causing issues here. Another thing to look at is if you’re running any sort of CDN in front of your site, that’s been known to block SVGs as well. Also, the latest version of the Safe SVG plugin is v2.0.1, so 2.4.2 isn’t an available release. That may have been just a typo but that’s something you can check again as well.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.