Support » Fixing WordPress » Image Upload jumps to new page

  • Resolved marathonmilk


    Hello all

    I don’t like having to post these messages but I really do need to get this issue fixed…

    I’m using the latest version of WordPress. When I click the upload image button, I get taken away from the edit post and the ‘lightbox’ window that pops up is displayed on a new page. Here is the link that the upload image gives me:


    Of course then, I am unable to insert an image into a post.

    I have Googled this before (with a wildcard * for the post_id) and there were some issues with it in version 2.7, I have found. I’m using the latest version.

    I did a complete reinstall of WordPress and still no luck.

    Am using Safari 5.0.3 on Mac 10.6.6 but have tried it with the latest version of Chrome on Windows 7 and no luck there either.

    Have reset cache, cookies etc.

    Running no plugins.

    Is there anyone out there that knows remotely how to fix this?

    Otherwise I’m a bit stuck.

    Thanks in advance,

Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    – increasing the memory available to PHP:


    Tried everything you said, nothing worked.

    Deleted everything again, deleted databases, deleted domain from Web host, started again.

    Nothing. Even in different browsers, it’s not working.

    My other WordPress blogs are fine, I really don’t know why this one’s not going.

    Very frustrating.


    OK, so I discovered there was an odd theme being installed along with WordPress. Deleting that solved the issue (somehow!).

    Thanks for your help anyway.


    Hmm, OK. That didn’t fix it. Deleted the blog and reinstalled again a day later. Nothing.

    If I want to insert an image, I get the ‘are you sure you want to navigate away from this page’ and if I click yes, it presents that image upload lightbox but taking up a whole webpage, same problem as my first post.

    Anyone… please…?



    The ‘odd theme being installed along with WordPress’…is it the twenty-ten theme?

    The next thing to try is to see if the blog posts display before you upload ANY new plugins or themes.

    From what you’ve described, you’re experiencing a javascript conflict. Poorly written plugins can do this, as can poorly written themes.

    No, I was using an ‘installer’ with my host for WordPress and it requires a different theme to be installed as well as the Twenty Ten theme.

    I just did a stock standard install of WordPress, manually uploading everything as standard.

    The image uploader works fine for the initial ‘Hello World’ post but any additional post doesn’t work (I get the image uploader taking up a full browser window).

    I’m beginning to think this is an issue with the host so I think I’ll contact them to see if they can fix it.


    Sorry, but I am running into a similar problem and I don’t understand the resolution here.

    My host is “hostgator.” I had previously uploaded WordPress Direct form something called the 30 Day Challenge. I converted to the latest version of WordPress. Once I brought the blog live, I switched to the “Platforms” theme. When I try to insert pictures into the post, it goes directly to a blank page with an “Id” url. From there I can get back to the dashboard by going backwards in my browser. Of course, if I do that no picture is displayed in the edit window.

    I have found that if I select the pic as a “featured image”, it will appear in the title. The pic is also uploaded into the gallery, It just won’t appear in the post where the cursor says it should.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Image Upload jumps to new page’ is closed to new replies.