WordPress.org

Support

Support » How-To and Troubleshooting » image upload issue since upgrade

image upload issue since upgrade

  • Upgraded to 3.4 yesterday and nothing but problems! Ugh.
    The first was that suddenly it is displaying “space” where forms have hidden fields. Huge space! Solved that by enclosing the hidden fields in a div with display:none style. Time-consuming. Thanks for that.

    At least I could work around it.
    Now I can’t upload images! At all.

    I do the upload thingy, it does its crunching thing and then shows the usual screen of details, options, etc for an image, but there is no thumbnail. If I copy the link and paste it to my browser, I get a 404. So I delete – which it does without a “can’t find that” error message – and try again. And again.

    I have tried uploading using the Media Library, and also by trying to upload to a single post. I have tried using the multiple file uploader as well as the single file browser uploader, all with the same results. No idea how to work around this one.

    Any help?

Viewing 15 replies - 1 through 15 (of 20 total)
  • Just tried logging out and logging back in. No luck.

    When you upload an image is it automatically stored in the /wp-content/uploads directory?

    Check that first and check that the permissions of the upload directory are correct. Refer to the following document for more information on file and directory permissions for WordPress: http://codex.wordpress.org/Changing_File_Permissions

    Yes, that is where images are uploaded, with additional year and month folder names. /wp-content/uploads/2012/06/

    I have tons of images uploaded already, and never had any problems doing so. Did version 3.4 change the permissions?

    Workaround: uploaded image with FTP to the uploads folder mentioned above. No problems with that, but it’s a far cry from the convenience of the WordPress media uploader, so I would like that resolved, if anyone can help out.
    Thanks!

    When you upload an image via the WordPress Media uploader, and when you upload an image using FTP, do you see a difference in the default permissions assigned to both images?

    When I upload with WordPress, it goes through the usual motions and I get this screen:
    http://img225.imageshack.us/img225/1371/image5pd.png
    As you can see, there is no thumbnail.
    If you were to copy and paste the File URL
    http://www.leeaaron.com/wordpress/wp-content/uploads/2012/06/Image4.jpg
    you would get a 404 error. That’s because it’s not actually there.
    I checked using FTP and the file is not physically there. The images I have successfully uploaded with WordPress prior to upgrading to 3.4 are there and have the same permissions (as listed in my FTP client) as the image I uploaded last night, using FTP.
    But the image I uploaded last night (by FTP), while it exists in the uploads folder mentioned previously (checked by FTP), does not show up in the WordPress Media Library.
    This Image4.jpg that I uploaded to show you the screen, is listed in the Media Library. Listed, but no thumbnail. When I click View, it shows me an archive-style page with the Alt text, but no image. If I click Edit, it shows me the same screen as capped above.
    I’m not sure if that answers your question about permissions, but as you can see, there are no permissions for anything uploaded with Media Uploader, because the files don’t actually get there.
    I should point out, in case it’s relevant, that I can make changes to posts and pages and that works. I can also create a new post without problems. Just can’t add pictures.

    It should be a permissions related problem, i.e. the user under which the webserver / WordPress is running does not have permissions to write new images in the uploads folder. Check out: http://codex.wordpress.org/Changing_File_Permissions

    In FTP, uploads folder and all subfolders are drwxr-xr-x
    The files in the folders are all -rw-r–r–

    In File Manager of cPanel, uploads folder and all subfolders are 755.
    The files in the folders are all 644.

    I have no idea what those mean. As far as I can tell, that gives User (me) permission to upload files. No?

    Moderator kmessinger

    @kmessinger

    The permissions above are correct.

    Have you tried:

    – deactivating all plugins (yes, all) to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s). If you can’t get into your admin dashboard, try resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    Gah. Somehow I knew it would come to that. Was just really hoping it was WordPress. OK. Will go do that now….

    Now I’m sad. I deactivated ALL plugins and still could not upload with WordPress. Now what?

    Is there a way to revert back to version 3.3?

    Moderator kmessinger

    @kmessinger

    You have a premium theme and need to upgrade it, http://diythemes.com/thesis/

    I’d rather revert to an older version of WordPress – one that worked with this theme. I hate this theme, but I don’t have the time to rebuild the site as-is using another theme. I feel like I may have modified this theme so the site displays properly, but I don’t know what I may have already done, and expect that an upgrade will eliminate my changes. As said, I don’t have the time to chase down stuff like that. I’d rather live with an older version of WordPress until I have time to modify another (free and supported) theme.
    Is there a way to revert to an older version of WordPress?

    Moderator kmessinger

    @kmessinger

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘image upload issue since upgrade’ is closed to new replies.
Skip to toolbar