Support » Networking WordPress » Image Upload Issue on Sub-directory Sites

  • Resolved kb123

    (@kb123)


    WordPress 3.8, Multisite installed thru godaddy. Sunrise.php moved to correct location, all files edited as need be.

    This is not my 1st use of WordPress Multisite, I have researched this issue, and see people with the same issues, but still cannot seem to correct this on my own.

    Main-Site: scrapmetalalloytester.com
    Sub-Site (Domain Mapped): innoifs-10.com

    I cannot upload any images to my sub-site. They just show up as a greyed out box in my media library.

    I currently have this in my htaccess:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>

    For the site setting, ‘wp-content/blogs.dir/4/files’ is what it is currently set as by default.

    Here is a page where an image should be: http://innoifs-10.com/?attachment_id=11

    I verified thru ftp that the image is there ‘/wp-content/blogs.dir/4/files/2013/12’ and all permissions are fine.

    Any help is appreciated.

    Thanks,
    Ken

Viewing 15 replies - 1 through 15 (of 29 total)
  • Upload path for main site: /home/xxxxx/public_html/wp-content/uploads
    Upload Path for sub-site: wp-content/blogs.dir/4/files

    I have checked my other multisite install’s upload path which is hosted on a different server.

    The main and subsites both have the same upload path, which is the same as my main site in question above. /home/xxxxx/public_html/wp-content/uploads

    I changed the subsited upload path above to be the same as the main, but am still having the same issue 🙁

    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    The main and subsites both have the same upload path, which is the same as my main site in question above. /home/xxxxx/public_html/wp-content/uploads

    Well that isn’t right.

    Upload path for subsitess should be /home/xxxxx/public_html/wp-content/uploads/sites/4/ OR wp-content/blogs.dir/4/files

    The first one (uploads/sites/) is for all networks created on WP 3.4 or older. The second one (blogs.dir) is for any network started on 3.5 or later.

    So for that your .htaccess should be this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Hi Mika,

    I changed .htaccess to what you posted above. Still no change. And Upload path remained the same for the subsite. wp-content/blogs.dir/4/files

    Thanks,
    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I just want to doublecheck something…

    SOME sites have upload paths of /wp-content/uploads/sites/#/…

    OTHERS (or one other) has /wp-content/blogs.dir/4/files

    Have you tried changing the theme on the site #4?

    Hi Mika,

    I just tried changing site 4 to the twenty fourteen theme (From Vantage), it had no effect. Images still do not display properly, upload path stayed the same.

    As stated, My main site (WP 3.8) where Multisite is installed has a upload path of ‘/public_html/wp-content/uploads’

    The sub site has one of ‘wp-content/blogs.dir/4/files’

    My other Multisite installation which is being ran on a different server is being run on WP 3.7 also using the Vantage theme, and has upload paths of ‘/public_html/wp-content/uploads’ for both main and subsites (and works fine).

    Thanks,
    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    The sub site has one of ‘wp-content/blogs.dir/4/files’

    That path is NOT WRONG in most cases.

    How many sites on the broken network do you have? Is this site the ONLY subsite? I’m asking for a reason 🙂 This will help me understand where the thing broke!

    My other Multisite installation which is being ran on a different server is being run on WP 3.7 also using the Vantage theme, and has upload paths of ‘/public_html/wp-content/uploads’ for both main and subsites (and works fine).

    I betcha not. I bet that your subsites are ACTUALLY putting files in /public_html/wp-content/uploads/sites/2/

    Is this site the ONLY subsite? I’m asking for a reason 🙂 This will help me understand where the thing broke!

    Yes, I didn’t want to add any more subsites until I had this figured out.

    I betcha not. I bet that your subsites are ACTUALLY putting files in /public_html/wp-content/uploads/sites/2/

    You may be correct, I’m just telling you what is showed when viewing the settings for the pages though 😉

    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    So to explain some history for you, if your multisite was activated on 3.0 through 3.4, the URLs for subsites would be wp-content/blogs.dir/#/files and the settings would reflect that exactly.

    If your multisite was activated AFTER (so 3.5 and up), you get /public_html/wp-content/uploads/sites/2/ but the settings say /public_html/wp-content/uploads/

    If you upgraded a multisite from 3.4 to 3.5, however, your urls were not magically changed.

    All this means? Your server doesn’t understand this line:

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    You need to check the httpd.conf file and make sure that “AllowOverride” is set to “All” or “Options All”

    So to explain some history for you, if your multisite was activated on 3.0 through 3.4, the URLs for subsites would be wp-content/blogs.dir/#/files and the settings would reflect that exactly.

    If your multisite was activated AFTER (so 3.5 and up), you get /public_html/wp-content/uploads/sites/2/ but the settings say /public_html/wp-content/uploads/

    If you upgraded a multisite from 3.4 to 3.5, however, your urls were not magically changed.

    Both installs were fresh. One from 3.7 one from 3.8. No upgrading done. 🙂

    You need to check the httpd.conf file and make sure that “AllowOverride” is set to “All” or “Options All”

    Cool, where do I find this file though?

    From the godaddy forums:

    You cannot edit the httpd.conf file on our web hosting plans. However, most changes can be done using a .htaccess file in the directory you want to the changes to take effect in.

    Thanks So Much,
    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    GoDaddy? You are now the SECOND person who has had this problem with GoDaddy. Did you happen to use their one-click magic installer?

    If there’s nothing to lose, I would start over and MANUALLY install WordPress.

    GoDaddy? You are now the SECOND person who has had this problem with GoDaddy. Did you happen to use their one-click magic installer?

    Yes I did. And now that I think about it. When I did my install on the other server, I setup Multisite manually. Godaddy has an option to auto-setup MU for you, which I used. So maybe something happened there.

    If there’s nothing to lose, I would start over and MANUALLY install WordPress.

    Thanks for trying.

    Ken

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    I’m starting to think that GoDaddy’s auto-setup of MU is janking you guys badly 🙁 I’m tagging this for their support rep to look into.

    Summary: When people are using the GoDaddy WPMU install, it’s causing their image upload directories to reflect the OLD directory structure for images instead of the new /wp-content/uploads one!

    Hello All,

    Just want to put out there that I am yet another GoDaddy customer who tried the one-click installer with the MU setup and mine does the same thing. It was a fresh install also.

    kb123, Did re-installing it manually fix the problem?

    Thanks,
    Eric

    Hi Eric,

    I haven’t done it yet. But as stated, in my previous installation. I did install WordPress via Godaddy, and manually setup MU,and had no issues. So I suspect you should be fine.

    Ken

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Image Upload Issue on Sub-directory Sites’ is closed to new replies.