Support » Fixing WordPress » Image upload http error

  • briang77

    (@briang77)


    Hi:

    One day I tried uploading an image to my blog and it will go the whole way till crunching then give an http error. I tried updating to 3.2.1 and it didn’t solve the problem. I can no longer post images to my blog, and cant seem to find a fix. I read the posts in this forum and tried modifying the .htaccess file and it didn’t help me.

    Any ideas out there? I’m really wondering how it happened? Are there any workarounds? I have tried installing other image plugins to no avail, I have tried uninstalling all plugins. I honestly didn’t mess with anything to cause this. I have subsequently tried updating wordpress files, but that hasn’t helped either.

Viewing 12 replies - 1 through 12 (of 12 total)
  • rkp1968

    (@rkp1968)

    i got the same problem… drives me crazy!!

    Ryan Yu

    (@geeksfolder)

    Have you checked the folder permission such as wp-content, uploads?

    If you don’t see wp-content/uploads/2011/09
    then your wordpress cannot create a new folder every month (by default).

    So check the folder & folder permission and see how it looks like.

    Maybe this thread would help.
    http://wordpress.org/support/topic/photos-not-uplading-properly?replies=10

    briang77

    (@briang77)

    I do have a wp-content/uploads/2011/09 folder. I even tried ftping an image into it, but wordpress can’t seem to find it to use in a blog post. V. frustrating. The only workaround I have is to post all my images on flikr and use links. Please help!

    This is my error message: Godaddy says its a wordpress problem.

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache Server at rescue.org Port 80

    Ryan Yu

    (@geeksfolder)

    Hi briang77,

    If it’s an Internal Server Error, let’s check your .htaccess file.
    1. Back up the current .htaccess file.
    2. Delete all of the code in the .htaccess.
    3. Add new .htaccess with the code below.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    refer to http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29

    Try this and let’s see how it goes.

    mennjoran

    (@mennjoran)

    I have the same problem, after all being fine earlier this month. I’ve tried replacing the .htaccess file code with the one above and there is no change.

    mennjoran

    (@mennjoran)

    All-

    I also use GoDaddy for hosting and found a solution on this forum: http://community.godaddy.com/groups/web-hosting/forum/topic/http-error-when-attempting-to-upload-files-via-wordpress/#post-267123

    Scroll down to see christianh’s solution to disable FastCGI

    briang77

    (@briang77)

    @mennjoran you are fabulous – made my day! THANKYOU SO SO MUCH! This worked. Turns out it was a Godaddy not a wordpress issue. GODADDY customer support TAKE NOTE!

    For other frustrated Godaddy customers who want the solution this is what worked for me:

    “I have reviewed this with our Advanced Hosting Support. The error that you are receiving is most likely caused from having FastCGI enabled for your PHP extensions. In order to correct this issue, you will need to disable it by following these instructions:

    To disable FastCGI

    1. Under My Products, select Hosting
    2. Click Launch
    3. Under Settings, select File Extensions Management
    4. Select Edit to the right of PHP file extensions
    5. Select the corresponding PHP version without FastCGI
    6. Click OK”

    mennjoran

    (@mennjoran)

    glad to have helped, and glad it was a fairly easy fix 🙂 Also relieved it wasn’t me who screwed it up. I hadn’t made any changes to my site, and I was beginning to lose my mind for a minute there!

    kmonahan

    (@kmonahan)

    I am having the same issue:
    WP 3.2.1, WAMP running locally on Win7

    I created a brand new WP site with new Db – no plugins installed – using default theme.

    IE8 -uploads works every time for every user

    Firefox and Safari – upload works for Admin user only. Http error for all other users.

    I even created another admin user – no go except using IE

    Can anyone else duplicate this? What makes the Admin user different from the other users? (And don’t say the Role – because I have another user in the Adminstrator Role)

    Why does User1 (Role=Author) – work in IE, but not Firefox or Safari?

    I have a WP site running WP 3.0.1 on same machine – no problems with uploads at all – works for all users with all browsers.

    Please help – this is making me crazy!

    I am going to see if I still have a frsh copy of WP 3.0.1 – and create another local site – and see what happens.

    kmonahan

    (@kmonahan)

    Actually – the Admin user doesn’t actually have a Role – so that makes him different..

    So is the problem that a Role is assigned? Why would IE be ok with that, but not the other browsers?

    Generally speaking – the difference between browsers is the way it handles javascript

    FYI – I have tried .htaccess fixes – and the Http error occurs when cruching goes to 100%. Also – this happens even for very small images – 10K or so. So this isn’t an issue with large files. (Besides – I am able to upload large videos using IE – my max upload size is set to 48M)

    One more thing – this issue is only with the flash uploader – the browser uploader works fine.

    Ok, so I have seen TONS of these errors all over Google, but not one single person ever really explained what the REAL PROBLEM was. Some of the previous solutions work if you’re using .htaccess to password protect the directory — but many are not protecting their directories. Some of the previous solutions will work if you’re on Godaddy Hosting — but many are not on godaddy hosting, so fastcgi isn’t the problem. So what could be the main problem?

    FOR ME, THIS WAS THE MAIN PROBLEM: mod_security

    On Apache, mod_security BLACKLISTS ^Shockwave Flash at REQUEST_HEADERS:User-Agent. Nearly 99.9% of apache servers have this setup as default. This is what the flash uploader from wordpress uses as the user-agent when it’s being used.

    This is a simple fix — just have your hosting company WHITELIST ^Shockwave Flash in mod_security. It’s blacklisted as a spambot by default — so if you change it (or your host does), you will no longer have this problem.

    This is NOT a browser issue, not an OS issue, etc. It’s just being blacklisted, that’s all. Take note, servers upgrade their apache software (including mod_security) all the time — and the newer versions might overwrite your current rules. So if this happens again later on down the road, then you know you need to whitelist ^Shockwave Flash again (if and when you get that silly http error ever again.)

    FYI: I discovered this because the http error is a 406 error, which is what made me look at the log files of mod_security. 406 errors should never really occur unless something is blacklisted.

    Call your host or do it yourself if you have a dedicated server. Trust me, this should fix the problem if you’ve tried everything else and none of it worked. 🙂

    Gonzalo

    (@gonzalo-sanchez)

    Everything indicates that the error “HTTP Error” while uploading images is caused by a change in the Apache FastCGI module (mod_fcgid 2.3.6) that limits the value of the parameter MaxRequestLen to 128KB (very low). Previously this limit was 1GB.
    Therefore this problem is likely to occur only on servers running PHP in FastCGI mode and only when trying to upload a file larger than 128KB.

    The final and stable solution to this problem is well explained in the link that leaves our friend ntarantino.

    http://wiki.mediatemple.net/w/(dv)_4.0:Enable_FastCGI

    and it works perfectly! 🙂

    but that solution requires access and modify the configuration file of FastCGI. It can be done via SSH or asking the support team of your server to do so.

    An intermediate and fast solution I’ve found, for those who need to solve this problem right now and can not modify that file themselves, is as follows:
    – Install the plugin WPlupload (nice and efficient plugin that replaces the WP file upload form)
    – In the plugin settings indicate 128kb or less in the “Chunk size”
    – Enjoy 🙂

    Tell me if this solution works for you.

    Gonzalo.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Image upload http error’ is closed to new replies.