Support » Fixing WordPress » Image Upload failed

  • Hi,

    i have a problem with image uploads. i tried to upload an image with has 4000x4000px and asize of 25MB. Upload works fine, but after upload where wordpress creates the thumbnails i get the error message: HTTP-Error. Nothing more. No thumbs are created. i connected with ftp to my site and in the upload folder there is only the orginal file.

    so where is the problem?

    i tried it with a rar archive of 30MB upload worked and no errors, also tried smaller images 1200x1200px and all worked fine.

    the stuff in my php.ini is more than enough i think. memory_limit = 256M, upload_max_filesize = 50M, etc.

    under Settings -> media in the admin backend i set the max file size to 6000x6000px.

    someone there who could help?

Viewing 4 replies - 1 through 4 (of 4 total)
  • catacaustic


    very awesome

    For that it’s not the size of the file when it’s uploading that’s causing the problems. It’s the size of the file when it’s being processed to create the thmbnails that’s causing the issues.

    Creating thumbnails takes a lot of server resources, and that’s not related to the upload size in most cases. Even though your file is around 25MB, that can take 10 to 20 times that amount or memory to process correctly, so 256MB just won’t be enough.

    The first thing I’d suggest resizing the images to a maximum of 6000×6000 and setting them to a compression ratio that you can live with before you upload them. This will bring the file size down, and will help with the processing issues. Even then, that’s a huge size for displaying online, so I’d like to know why you need the images to be this big? I’m sure there’s a reason that I don’t know about yet.

    There might be other things that you can do, but without knowing how you’re using the images on your site it’s hard to suggest anything more.


    first i don’t need those image sizes. it was only a test because 1) it works with the same fiile on hosted blog. i don’t think that i have so much more ram there?!? (i think no but it is working extremly fast there) and 2) the crappy ios wordpress ap only allows image sizes: small, middle, large and original and the problem there i have is that on size large the app resizes at the widest side at 1024px.

    on a landscape format image it is perfect but on a image in portrait mode the smaller side is too small for me, because the app resizes the larger side to 1024px. but i want the smaller side at 1024px.

    on older app version i could the size. At the latest app version i could only select between the sizes described above and the app resizes the images not as i want.

    so for this i checked if the upload failure came when i use size original on images. with the app i get an error message, so i tested it local onmy own webhost and there the same problem (see first post of me). so that’s why i uploaded images with that huge size 🙂



    very awesome

    The first thing to note is that WordPress.COM probably does have a lot better CPU and RAM allowances then anything that you’ll find in a shared hosting environment, so having it work there has no corelation to it working anywhere else. I don’t know what their system is like, but there’s always the possibility that they offload things like that to other servers to share the load, or it could be any of 1,000 other things that they have set up that allow that to happen for their own systems.

    In relation to the image sizes that you want, I’m not sure how the mobile version works (because I don’t use it), but I’d guess that it gets the image sizes that are set in the ‘Settings -> Media’ section of your admin area. The sizes that you’ve said there sound exactly like what’s set by default. You’re going to have two choices. Those are either update the sizes in that area to something that matches your requirements, or you can use add_image_size() to add your own custom image sizes into the system.

    okay i noticed it. tried it again by setting the sizes in the admin area. these setting did not influence the app. so the app uses own sizes which are in the code there i think. so i have actually no options to change the size to my own wish-sizes. i think i have to wrote to the support for the ios app ..

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image Upload failed’ is closed to new replies.