WordPress.org

Forums

[resolved] image upload error - wrong upload folder path (8 posts)

  1. connectto
    Member
    Posted 3 years ago #

    I'm having trouble uploading images on my wordpress

    i found the following error message:

    “travelcouture.jpg” has failed to upload due to an error
    Unable to create directory E:\home\travelcout\Web/wp-content/uploads/2012/02. Is its parent directory writable by the server?

    I noticed that the address in question does not exist E:\home\travelcout\Web/wp-content/uploads/2012/02 .. this is not the correct address of this folder on the web or in my internal server for testing .. I do not know this "E:\home" ..

    I have done a search here at the forum and google in general and tried the following solutions - none worked:

    - set all the folders with the configuration 777 (already)

    - "Store uploads in this folder" - set to "wp-content/uploads"
    although it is already warning that this is the default at wordpress admin - also did not work - set back the original empty default

    - Tried to change the "Full URL path to files" to the correct address http:/www.travelcouture.com.br/Web/wp-content/uploads/ but also did not work - went back to the original empty default

    - Tried to create a new folder "uploads" - did not work

    - Tried to create a new folder with a different name "upload" and set the new path through the "Store uploads in this folder" to "wp-content/upload" - did not work - I went back to the original empty default and set the folder name back to "uploads"

    - inside the upload folder i found subfolders "2012" and inside that another subfolder "01"

    as the error says failed to create the folder "02" I tried to create this folder - then got a different error: "HTTP error"

    deleted this "02" folder

    - tried to turn off option "Organize my uploads into month- and year-based folders" - did not work - but change the error message - now it shows "HTTP error"

    Anyone know how I can fix this problem by correcting the wrong path or otherwise?

    thank you in advance

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try changing the permissions on the wp-content directory to 766 and remove any sub-folders that you added mnaually. If you still have problems, try 767, 775 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.
    http://codex.wordpress.org/Changing_File_Permissions

  3. connectto
    Member
    Posted 3 years ago #

    hello esmi really thanx for your answer

    actually everything is already set to 777 - it seems to be default in the server im hosted and i cant change this number via ftp.

    this seems to be other kind of error.

    the first test i found on google about it was to change the permissions to 777 and when i check everything was already set to 777 so shouldnt experience thins kind of problem..

    anyone have this same error ? please help hehe :)

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Delete any uploads folders that you created manually insider wp-content. It is vital that WordPress creates the folder(s) itself. If that still isn't working, try contacting your hosts. This could be a folder ownership issue rather than a permissions one.

  5. rfair404
    Member
    Posted 3 years ago #

    I find this path odd. E:\home\travelcout\Web/wp-content/uploads/2012/02

  6. esmi
    Forum Moderator
    Posted 3 years ago #

    Looks like a Windows server path. Or a localhost install.

  7. 12much
    Member
    Posted 3 years ago #

    I find this path odd. E:\home\travelcout\Web/wp-content/uploads/2012/02

    Hi All, it isn't that odd. It is in your settings and can be changed. WP actually makes the directory as YYYY/MM so 01 is january etc.

    In my case it wasn't possible either and due to administrator rights. They did the installation for me and forgot to change their own Login and PW. After that I could write the dir's myself, upload media without any errors. I see a questionmark now instead of the thumbnail. But I'll try to delete the dirs I made first like Esmi adviced. Check your host, he has to do something first.

  8. connectto
    Member
    Posted 3 years ago #

    solved - change my windows host to linux host

    thanx :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags