WordPress.org

Forums

Image Upload Error (17 posts)

  1. ERP
    Member
    Posted 1 year ago #

    Since my last post on April 24th, I have been unable to upload any images. I receive the error: "An error occurred in the upload. Please try again later."

    I've done a bit of research on the issue and have tried deactivating all plugins, but that does not resolve the issue.

    I have read that changing permissions to 777 could help, but I am not sure how to do that.

    Any help/advice is greatly appreciated.

    Thanks!

  2. Mark (podz)
    Support Maven
    Posted 1 year ago #

    What size - in pixels - are the images? This can happen if they are very large so it's worth resizing them before upload to something less than maybe 3000 pixels on the longest side.

  3. echoleaf
    Member
    Posted 1 year ago #

    Is this pixel dimension a known issue? I've had some similar issues and following your suggestion, an image with the max length of less than 3000px uploaded fine.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Is this pixel dimension a known issue?

    It can occur if the files are simply too large. Try uploading an image that is 600px wide or less.

  5. echoleaf
    Member
    Posted 1 year ago #

    I had success when I resized images with a max width of 4288px to 2800px. 600px is a good testing size.

  6. strony-www.net
    Member
    Posted 1 year ago #

    try disabling some plugins,
    for me sitemap generator plugin blocked this option

  7. nippi9
    Member
    Posted 1 year ago #

    This seems to be a common error, with many threads on the topic.
    Mods only input seems to be "start your own thread" so there are many threads now start, none of them solved on this issue, which has been going on for years.

    Sure, sometimes its an errant plugin, but no one has ever come up with the solution "its becuase this plugin is doing this" which is problably the solution for all instances of this error.

    Myself? I have the same issue, with a theme and set of plugins which are working on another domain, identical setup, on the same server.

    i am not going to start my own thread, because i can see its not a different problem its the SAME problem and in any case, no one has made a genuine attempt to solve it. I would start another thread, only to see nothing happen.

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    I had success when I resized images with a max width of 4288px to 2800px. 600px is a good testing size.

    It does sounds like the images you trying to uploading are too large and, as a result, are trying to consume more PHP memory than your hosts will allow. Try checking your site's error logs for messages relating to PHP memory to confirm. Your hosts should be able to help you accessing your site's error logs.

  9. echoleaf
    Member
    Posted 1 year ago #

    Thanks, I am following up with the host.

  10. asoutiyal
    Member
    Posted 1 year ago #

    most probably plugin conflict. try to disable all plugins at once and try to upload images.

  11. nippi9
    Member
    Posted 1 year ago #

    Original poster states problem occurs with all plugins disabled.
    Esmi.
    It happens for me:-

    a. all plugins disabled.
    b. any image size.

    Noting regarding your answer? you are not answering the problem raised by the original poster, you are agreeing with someone who fixed their problem.

    irrelevant right? The original poster(as well as I) can load NO images of any size. Small or large.

    And no need to delete me just because i am critical of how this particular problem is being handled(its not really being handled). Thats just silly.

  12. ERP
    Member
    Posted 1 year ago #

    My image size is the same as the images I have previously uploaded. I uploaded some just hours before the problem began. Size isn't an issue. I need a fix for this. I am a wedding photographer, so the ability to upload images is important. Any other ideas?

  13. esmi
    Forum Moderator
    Posted 1 year ago #

    Try uploading an image that is 600px wide or less.

  14. esmi
    Forum Moderator
    Posted 1 year ago #

    @nippi9: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. As per the Forum Welcome, please post your own topic.

  15. nippi9
    Member
    Posted 1 year ago #

    Fine.... though I think anyone here would be happy with some rudeness over protocol if it meant getting an actual answer to a problem posted time after time for years with no solid answer provided.

    Protocol following keeps being demanded.
    Answers keep not being provided.

    Let me do it now.

    The answer to this problem 9 times out of 10, is memory allocated to PHP

    It might be being caused by your theme using too much.
    It might be being caused a plugin or plugins using too much
    Maybe your images are too large.
    A wordpress update could have caused your site to reach a tipping point.

    Solutions like changing hosts or themes often work... as the new host allows more memory to be used, or the theme swapped in uses less.

    But its almost always memory.

    Check your php.ini and get it as high as possible, then trouble shoot what is sucking the memory available to php

  16. esmi
    Forum Moderator
    Posted 1 year ago #

    The answer to this problem 9 times out of 10, is memory allocated to PHP

    All of this has already been stated above.

  17. nippi9
    Member
    Posted 1 year ago #

    if you mean directly above? yes. you are right.
    If you meant above me? Untrue.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.