Support » Fixing WordPress » Image Upload Error

  • Resolved cloud3z


    Hi, I have recently installed the latest WordPress, which is 2.1.2

    The only thing that I have problem now would be the uploading images to my posts.

    I use the plugin “Downloads for WP” where it locates my folder for downloads, and “Flexible Upload” to upload and insert images to my post.

    However, after uploading the image, an error was there where it said:

    “Fatal error: Allowed memory size of 8388618 bytes exhausted (tried to allocate 800 bytes) in /home2/jonloh/public_html/wp-admin/admin-functions.php on line 2153”

    And then, I found out that under the “Browse” tab, there is an error on the URL field which I do not know how to rectify it as I couldn’t edit it. That might be causing the problem or so.

    I’m wondering if someone could help me out on this. Your help is very very very much appreciated.

    I have uploaded screenshots for better view and understanding to this problem:


Viewing 3 replies - 1 through 3 (of 3 total)
  • If your PHP is compiled with memory limit checks, the default is 8MB which is much too small. You should increase this to at least 32MB or 64MB to avoid PHP out of memory errors. Look for “memory_limit” in your php.ini file.

    Thanks for the reply.

    Just for further information, is the php.ini under the WordPress folder or on the server side?

    I’ve got the same error since I upgraded to version 2.1.3. It didn’t happen with version 2.1.2. And it isn’t problem of the memory limit (mine is 40MB).
    This is the error I get (the same as cloud3z):
    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 5120 bytes) in /home/quae/public_html/astronomipedia/blog/wp-admin/admin-functions.php on line 2161
    And cloud3z, the php.ini can be in many places. For example, mine is in the root, but in another hosting I’ve got, I can’t access to it.
    Sorry if I’ve made any mistakes, I’m sorry. I’m Spanish.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Image Upload Error’ is closed to new replies.