WordPress.org

Support

Support » How-To and Troubleshooting » Image Upload Does Not Display Errors

Image Upload Does Not Display Errors

  • This has been a long standing problem for me. I am having problems with uploaded images and am unable to properly troubleshoot because the image upload feature does not display errors.

    The root problem is that the image upload feature does not display error messages. The symptoms are that thumbnail images are not being generated my theme (AutoFocus) cannot display EXIF data for images.

    Scenario: I am uploading a 800×600 143KB color JPEG image. The Flash upload tool shows the status bar going to 100%, Crunching… and then stops once the bar clears itself and the “Save all changes button” appears. Nothing else happens. No image thumbnail is displayed, no image information (titles and descriptions) is displayed.

    When I close out the ‘Add an Image’ window and reopen it I can see the image in the Gallery but there are no resized images available (thumbnail, medium, large) and the full size dimension is listed as 0x0. When I choose to Edit Image I get the error “Image data does not exist. Please re-upload the image.”

    I repeat the upload process using the browser upload method. Once the image is uploaded the ‘Add an Image’ window is cleared and is left blank. Closing the window and going into the Gallery yields the same results as the Flash method above.

    General

    * OS: Linux
    * Server: Apache/2.2.3 (Red Hat)
    * Hostname: blog.radian.net
    * IP:Port: 76.12.173.65:80
    * Document Root: /vservers/h77483wp/htdocs

    PHP

    * v5.1.6
    * GD: bundled (2.0.28 compatible)
    * Magic Quotes GPC: Off
    * Memory Limit: 16.0 MiB
    * Max Upload Size: 30.0 MiB

    MYSQL

    * v5.0.77
    * Maximum No. Connections: 100
    * Maximum Packet Size: 1,024.0 KiB
    * Data Disk Usage: 3.8 MiB
    * Index Disk Usage: 283.0 KiB

    http://core.trac.wordpress.org/ticket/12532

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Image Upload Does Not Display Errors’ is closed to new replies.