Support » Fixing WordPress » Image Upload Curiosity

  • Resolved radscheit



    I’m experiencing some problems with the media upload in wp. By loading up media – let’s say an image – i get an unspecified failure dialogue from wordpress. And I don’t see a thumbnail nor i have the possibility to put the image in my post. But i switch to the media library, the pic is inside. But when I get back to my post in order to load a image from library, is is empty.

    I host WP on a V-SERVER with Plesk 11.5.3 with enough disk space and right chmod setting for /uploads und its subelements. I spent hours of googling with no result :/

    I’m thankful for every idea….

Viewing 12 replies - 1 through 12 (of 12 total)
  • Oh and i don’t use any image plugin…

    and i run php 5.3



    Switch browser and verify if it works, if not than verify the “uploader” file permissions, set it to 777 and upload any image to see if it works. if you get n error message you can add it , so I or anyone else can help here.

    Thanks for your answer.

    Do you mean the upload.php in the wp-admin and the uploader dir beside it? If so the solution didn’t work for me. Here you can see the failure dialog in german:

    TRANSLATION: “An Error occured. Try it later.” Interesting detail: The shown file name in the failure message doesn’t match the original file name.

    Do you have any further ideas? 🙂 Thanks in advance!



    No it’s the Uploads folder, there is no extension like php or others (just a folder where you can see months and years inside it, example, 2014, then the months numbers, 02. 03 etc…)
    When you want to open your site files from Cpanel file manager, make sure to check the box that says “Show Hidden Files (dotfiles)”.
    Please make permissions 777 for the folder “Uploads”, then open it and change the month 03 permissions to 777 also, come back and create a new blog post, upload an other image to verify.
    Important note: If you still get that error, do as below:
    Save the post as draft, just to refresh the page and re-upload the image again. This worked for many others.
    I hope this will solve the issue.

    Thanks again, for your help. I tried the suggestetd solution before I opened this thread and it didn’t work. I did it again to be sure but it’s the same.

    Is it my functions.php? Other Installation of worpress are working fine on my server:

    'add_theme_support( 'post-thumbnails' );'
    'function custom_post_type_team() {
    	$labels = array(
    		'name'                => _x( 'Teamitglieder', 'Post Type General Name', 'Team-Mitglieder' ),
    		'singular_name'       => _x( 'Teammitglied', 'Post Type Singular Name', 'Team-Mitglieder' ),
    		'menu_name'           => __( 'Teammitglieder', 'Team-Mitglieder' ),
    		'parent_item_colon'   => __( 'Parent Item:', 'Team-Mitglieder' ),
    		'all_items'           => __( 'Alle Teammitglieder', 'Team-Mitglieder' ),
    		'view_item'           => __( 'View Item', 'Team-Mitglieder' ),
    		'add_new_item'        => __( 'Neues Teammitglied hinzufügen', 'Team-Mitglieder' ),
    		'add_new'             => __( 'Neues Teammitglied', 'Team-Mitglieder' ),
    		'edit_item'           => __( 'Teammitglied bearbeiten', 'Team-Mitglieder' ),
    		'update_item'         => __( 'Teammitglied aktualisieren', 'Team-Mitglieder' ),
    		'search_items'        => __( 'Teammitglied suchen', 'Team-Mitglieder' ),
    		'not_found'           => __( 'Teammitglied nicht gefunden', 'Team-Mitglieder' ),
    		'not_found_in_trash'  => __( 'Teammitglied nicht im Papierkorb gefunden', 'Team-Mitglieder' ),
    	$args = array(
    		'label'               => __( 'team', 'Team-Mitglieder' ),
    		'description'         => __( 'Hier können Beliegbig viele Teammitglieder angelegt werden', 'Team-Mitglieder' ),
    		'labels'              => $labels,
    		'supports'            => array( 'title', 'editor', 'excerpt', 'author', 'thumbnail', 'comments', 'trackbacks', 'revisions', 'custom-fields', 'page-attributes', 'post-formats', ),
    		'taxonomies'          => false,
    		'hierarchical'        => false,
    		'public'              => true,
    		'show_ui'             => true,
    		'show_in_menu'        => true,
    		'show_in_nav_menus'   => true,
    		'show_in_admin_bar'   => true,
    		'menu_position'       => 5,
    		'menu_icon'           => 'dashicons-businessman',
    		'can_export'          => true,
    		'has_archive'         => true,
    		'exclude_from_search' => true,
    		'publicly_queryable'  => true,
    		'rewrite'             => false,
    		'capability_type'     => 'page',
    	register_post_type( 'team', $args );
    // Hook into the 'init' action
    add_action( 'init', 'custom_post_type_team', 0 );'

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    radscheit? Please do not se single quotes for code blocks here. It doesn’t work and I’ve added the backticks above.

    ok, thanks for the evidence.

    The couriosity is that the pics are in the media library but no avaiable in the post add media oder set featured image view… 🙁

    I’ve tried to reinstall, but that didn’t solved the problem. Any ideas?



    Please change your browser, try with Firefox or IE, at the same time change your actual theme to one of the default WordPress themes, if this can’t solve the issue, then you need to contact your hosting provider.

    I’ve found the bug 🙂

    'taxonomies' => false,

    I don’t know what it has to do with it. But WP_DEBUG showed a failure on post.php line 1334…

    But thanks for your suggestions 🙂



    Good to hair that, Good Luck:)

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Image Upload Curiosity’ is closed to new replies.