Support » Fixing WordPress » Image Upload Crunching Error – Out Of Memory

  • I have spent hours and hours researching this problem and trying other peoples fixes but had no success.

    I installed the latest build of WP 3.4.1 on my VPS and also on my local PC running WAMP. When uploading an image in WP on my local PC, it works fine with no problems and I can upload any sized photo. However when uploading photos in WP on my VPS, I keep getting an error when crunching “Out Of Memory” and it refers me to line 258 in media.php. The image uploads but no thumbnail is produced and this error always shows up. Only if I upload something around 640×480 or less will it work without an error.

    – I have commented out line 258 and changed line 263 to “return $file;” and that suppresses the error but it doesn’t produce the thumbnails and is only a temporary workaround.
    – I have increased my PHP memory limits (php.ini) on the VPS to 256M (restarted apache) and also WP memory limit to the same but still no luck. The local version of WP on my PC has memory limits set MUCH lower and it still works fine.
    – I have done a CHMOD 777 on the upload directory.

    I cannot figure out what on earth is going wrong here??? Please help as I have run out of ideas.

Viewing 2 replies - 1 through 2 (of 2 total)
  • try reinstalling WP.

    Also for the site memory —

    ..line in the wpconfig file, try relocating it towards the middle of the file.

    Thanks for the reply. Tried that as well as modified the config file to increase memory limits and still no luck.

    The unusual thing is I installed WP on my local PC running WAMP and it works perfect out of the box. I have even decreased memory limits on my local PC to see if I can replicate the problem and I can’t!

    I’ve had software developers and networks engineers trying to sort this one out and still no solutions!

    If anyone can give any other recommendations, that would be appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Image Upload Crunching Error – Out Of Memory’ is closed to new replies.