Support » Fixing WordPress » image upload

Viewing 15 replies - 1 through 15 (of 38 total)
  • Is your question how to do image uploading? In your WP admin page, clk on ‘File uploads’, set use_fileupload to ‘true’, set the fileupload_realpath, fileupload_url. You may want to change fileupload_maxk to 2048. I left fileupload_minlevel to 1 and fileupload_allowedusers to ‘admin’. Update the settings and go to yourblog/wp-admin/upload.php and upload your images.

    I can not make this feature work. To be specific, when uploading it goes through the process and also creates the correct path in the source link, but it never uploads the file (even though it tells me it did).
    I tried varying the true path name, thinking I made an error there, but no success.
    For now I upload the image manually but generate the code for the post via WP.
    I’ve seen nobody else having problems with this, I’m stumped.

    I am.
    I’ve gotten the most recent upload.php build, double-checked the options and relaxed all the permissions, too.

    I have the same problem, what can I do?

    hi, i know this might be a stupid question, but did you create the images folder that it uploads to?
    if it says it’s uploading to http://yoursite/blog/images do you actually have an images folder there?

    Usually hate me, too posts, but:
    me, too.
    It seems to go through the process, indicates success, no image in post nor folder. There have been other threads mentioning this problem, and given the others response, you are not the only one.
    But overall, wordpress is just such a great application, and still in development, so I just do it using ftp, and image tag.
    William
    http://WilliamBragg.com/wordpress

    oh, so yours does have the image folder?
    because i had forgotten to make the directory and it had pretended to me that it uploaded it to the directory which didn’t exist…
    i’d felt so stupid 🙁

    Yes, directory exists. I also tried with relaxing permission. Probably sounds pathetic, but I’m “glad” to hear that I am not the only one with this specific problem, makes me feel less dense. I’ll just handle it via ftp – the WP photo hack works just fine, and I might go for only using that – sofar the image upload was used for these odd end things which didn’t seem fitting to use the photo hack for and for those cases the ftp upload isn’t a biggie.
    With b2 I used a hack which I liked, which created a thumbnail on the fly. I might try incorporating that one into it, though the current one had a lot of visual similarities to that hack, so it might already be based on the same one.
    Still seems weird as the image upload now does to work for some, but not for others – which makes me guessing, it is all the same something with the true path, which I just set to “/images” (also tried “/images/” for good measure, I even tried “images”) as the folder called ‘images’ resides on root level within my domain.

    do you have your realpath and your url set right?
    like um
    fileupload_realpath: /home/(user_name)/public_html/images
    fileupload_url: http://yoursite.com/images
    i really wish i could be more help…

    I went through the process again trying to make it work and when there was still no go, I then had the (finally) glorious idea to log in via SSH and locate an image file which had been already uploaded into the images folder to ensure I get the correct realpath. Then it finally dawned on me – I am not in a ‘standard’ setup with a /home/usr/public_html/ setup but I am setup as a user on that server where /home/ corresponce to a directory called “WebSites” and after changing that, it finally – worked!
    Thanks for your suggestions, it made me – look again 😉

    YAY!!!
    so it was your realpath or something
    i’m glad it got working
    now if only someone could direct me to figuring out my problems 🙂

    I have the same problem, its cool!!

    So, is it fixed now?

    If it is fixed for you, I am assuming that your WordPress is hosted on a Mac OS X server and the WebSites folder gets used by you or your ISP as home folder for the various domains.
    Lilandra, yes, it was a realpath issue.
    I’d love to be able to help you with your problem you mentioned, but as I don’t know what it is, I don’t know 😉

    it’s the RSS feed…
    but i’ll have to get back to you on that..i’m updating
    *fingers crossed*

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘image upload’ is closed to new replies.