WordPress.org

Support

Support » Plugins and Hacks » Image Slider JQuery problem

Image Slider JQuery problem

  • Hi, I am trying to implement a meta slider on this site: http://seguinmoreaunapa.com. I am using the free version. The theme is a custom one built on twenty eleven. If I put the code in the theme homepage.php the slider does not display. If I use the shortcode and just put it into a page it works brilliantly. I am not sure if there is a jQuery script loading twice. I posted on the plugins forum but have not heard back. I am trying not to buy the pro version for $19. Any ideas? Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • It looks like you’re trying to use Nivo Slider, but you haven’t loaded the .js file.

    You will want to upload the .js file somewhere on your web server (in your theme’s folder, in a sub-folder called ‘js’ maybe?), then load it using wp_enqueue_script in your theme’s functions.php file.

    Example:

    function load_my_scripts() {
        wp_enqueue_script(
            $handle = 'nivo_slider',
            $src    = get_stylesheet_directory_uri() . '/js/jquery.nivo.slider.js',
            $deps   = array( 'jquery' )
        );
    }
    add_action( 'wp_enqueue_scripts', 'load_my_scripts' );

    It looks like there is also some CSS that needs to be loaded for Nivo Slider. Use wp_enqueue_style for that.

    Hi Shaun,

    Why does the test slider work on just a normal page, but not on the homepage?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Image Slider JQuery problem’ is closed to new replies.
Skip to toolbar