Support » Plugin: Simple Image Sizes » Image size update bug(?)

  • Resolved skafte

    (@skafte)



    Hi there,

    Hope you are well.

    Firstly, thanks for providing such a brilliant plugin to the WP community!

    I updated WooCommerce today, which I’m using on my site, and just to be safe, I checked that the image sizes hadn’t been overwritten (as that has happened in the past somehow). To my disappointment they had, and so I started looking into updating the sizes myself manually. Unfortunately I then realised that the sizes in the ‘Image sizes’ field didn’t correspond to the sizes in the ‘Thumbnail regeneration’ field and that I couldn’t update the sizes successfully. To show you this issue in action, please take a look at this screen-recording – as you can see, the updating of the image sizes does not stay after I’ve saved the changes or reloaded the page. And the changes also aren’t effective if I regenerate the thumbnails just after I’ve updated the image size (not shown in the video clip).

    Any ideas to why this is happening? I’m using W3TC, but I’ve put it in development mode and cleared all caches etc. I’ve also deleted and reinstalled the Simple Image Sizes plugin, but with no luck.

    Any help would be highly appreciated!

    Thanks,

    Jonas

    https://wordpress.org/plugins/simple-image-sizes/

Viewing 7 replies - 1 through 7 (of 7 total)
  • — UPDATE —

    Hi again,

    I’ve now tested this on another site and unfortunately I’m experiencing the same problem there. For a while I thought it had to do with the theme that I am using, but as it’s also happening on a completely separate site with a different theme by a different developer, I am starting to think that this is actually a bug in the plugin.

    I’ll keep searching for answers. So far I’ve deactivated, deleted and reinstalled all image handling plugins (Simple Image Sizes and WP Retina 2x), but with no luck.

    I’ve also tried to manually add the below code directly to the functions.php file, but that didn’t work either!?

    add_image_size( 'shop_thumbnail', '70', '87', true );
    add_image_size( 'shop_catalog', '380', '472', true );
    add_image_size( 'shop_single', '511', '635', true );
    add_image_size( 'product_small_thumbnail', '116', '145', true );
    add_image_size( 'shop_single_small_thumbnail', '511', '635', true );
    add_image_size( 'blog-isotope', '436', '0', true );

    I’m wondering if somehow these standard sizes of the themes are somehow stored on the database? Although I’ve cleared all caches and used a database optimiser, but that didn’t work either… Strange!

    I’ll keep you updated meanwhile I’m hoping to hear back from someone with a solution.

    Thanks,

    Jonas

    — UPDATE —

    I’ve now also deleted the option ‘custom_image_sizes’ in the database and put the numbers back in. That didn’t work either…

    🙁

    By the way – the screen-recording that I linked to above can be seen better if downloaded…

    Ok. I’ve found a solution – but simply by not using Simple Image Sizes at all.

    I changed the following code in the functions.php file to my needs:

    add_image_size( 'blog-isotope', 436, 0, true );

    And further down the file:

    $catalog = array(
    		'width' 	=> '380',	// px
    		'height'	=> '472',	// px
    		'crop'		=> 1 		// true
    	);
    
    	$single = array(
    		'width' 	=> '511',	// px
    		'height'	=> '635',	// px
    		'crop'		=> 1 		// true
    	);
    
    	$thumbnail = array(
    		'width' 	=> '70',	// px
    		'height'	=> '87',	// px
    		'crop'		=> 1 		// false
    	);

    I hope that flagging this issue and sharing how I solved it (without using the plugin) can help to make the plugin stronger as if so then I’ll definitely go back to using it again.

    Thanks,

    Jonas

    Plugin Author Nicolas Juen

    (@rahe)

    Hi !

    Sorry for the response lag, this is due to the change i’ve made for the 3.0.8 to use the after_theme_setup filter instead of init.
    So with the new version from github repository : https://github.com/Rahe/Simple-image-sizes this will work.

    Can you test ?

    Hi Nicolas,

    Thanks for this! Worked like a charm! Brilliant…

    Have a nice rest of the week.

    Best,

    Jonas

    Plugin Author Nicolas Juen

    (@rahe)

    Oh cool !

    Then I will make the 3.0.9 tag soon 🙂

    Thank you very much and have a nice week too.

    Plugin Author Nicolas Juen

    (@rahe)

    Version 3.0.9 is out 🙂
    Rahe

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Image size update bug(?)’ is closed to new replies.