Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Image Size of old WordPress editor compromised?

  • Resolved Snake-Plissken

    (@snake-plissken)


    It seems ever since I have installed photonic I have an issue with my images when inserting them into a post.
    It could be a coincidence, I am not sure.

    So thats whats happening. I use the standard and old wordpress editor to write posts. (not Gutenberg)
    I add images via the “add media” button on top of the editor window

    The size I select to insert is large which should be 1000×650

    however, recently the large size has changes to 1000×650 – 640×480. The problem now is, that every new picture which gets inserted gets a with attribute of 640 added instead of the 1000. I already checked the wordpress- media settings for image sizes and there everythign is still at 1000 for large.

    Look at this post: when you see the large images which take up the full column width, thats how it used to look like.
    https://gatetoadventures.com/spacex-radarsat/
    Now its looking like this. The image gets reduced automatically while inserting.
    https://gatetoadventures.com/testpage/

    Any ideas? Thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Sayontan

    (@sayontan)

    Are you referring to the first photo, which says “Photography Strictly Prohibited”? That isn’t from Photonic. A cursory inspection of your page’s source code shows that there is some plugin called PanoPress, which is setting a width of 640px on your images.

    Snake-Plissken

    (@snake-plissken)

    Hi,

    yes, thats how it should look like. I had to change it manually in “source code” of the editor to get the full size. Now new images get added with a 640 width tag. Yeah there is a plugin panopress, but tried to deactivate it too and still the same. I also deactivated photonic but it has still the same weird behavior of adding this 640 width attribute.
    I just noticed that after installing photonic, it might be just a coincidence…I am not very good in coding and all that.

    Plugin Author Sayontan

    (@sayontan)

    Photonic adds no custom image sizes and really does nothing in terms of touching existing Media Library settings. It also has 0 impact on your gallery creation itself.

    Moreover:

    I also deactivated photonic but it has still the same weird behavior of adding this 640 width attribute.

    If the behaviour remains when you deactivate Photonic, that would imply that Photonic is unrelated to this.

    The behaviour you are reporting could be because of several reasons: your theme might be setting it, or you may have added a different plugin, or you might have inserted the two photos using different methods etc. You might want to disable all plugins and try inserting the photos. If the problem persists with 0 plugins then your theme is likely to be the culprit. If the problem doesn’t exist with all plugins disabled, try activating the plugins one by one to see which one is causing the issue.

    This much I can guarantee you – Photonic doesn’t do this. Photonic fetches photos with the exact specifications that you are asking it to use. More importantly, it does not touch photos that are not inserted by Photonic, particularly if the plugin is deactivated (WP will prevent it from doing anything if deactivated). I can stake a month’s salary and my entire reputation as a WP developer on this 🙂

    Snake-Plissken

    (@snake-plissken)

    Thats fine, I belive you. I was just curious. I tried to change the media size in wordpress settings. it changes the first set of numbers in the dropdwon but it still adds the stupid width attribute. I have to dig deeper into that.

    Thanks for the help anyway. I wasn’t sure, if photonic set some custom image sizes.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.