Support » Plugin: Jetpack - WP Security, Backup, Speed, & Growth » Image resolution for follow on wordpress.com notification mails

  • Resolved torstensbuechereckede

    (@torstensbuechereckede)


    Hi,

    If I’m setting “individual size 200 px” for pictures in blog posts this is not used for follow functionality via wordpress.com. In the eMails allways full size is shown for every picture ignoring the size limitations in the blog post settings. In the post byself size restriction is working without problems. This looks very ugly in the Mails if original pictures in posts have different sizes. I don’t want to change the physical size of the images because the additional resolution is needed e.g. for other areas where the pics are shown larger.

    How can I fix this?

    The page I need help with: [log in to see the link]

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Post – good

    Mail – not good

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi there!

    The best solution to try in this case is to switch to something with a better markup for multiple images, like galleries:
    https://jetpack.com/support/tiled-galleries/

    This would allow a better rendering in the inbox (please also note that the way the email is displayed can change depending on the email provider and the software you use to check your emails).

    Let me know how you get on with it!

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Hi,

    Thank you for the answer. The problem with gallery is that pictures are fitted automatically and individual size is not possible. This seems to be even more worse.

    I think this is not a problem of the provider but in mail the settings (size) which are used in webdisplay are not used. It looks like in post creation where individual sizing settings are also ignored.

    It looks like in post creation where individual sizing settings are also ignored.

    Do you mean that the images appear like this in the post editor as well?

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Yes, in the editor it’s the same as in the mail. Only after posting it looks good in preview or final view.

    Example: The picture has the size 237×346. I have set this to individual size 137×200. This means editor ignores it, email ignores it. Final und Preview web view are working with 137×200. Furthermore Facebook / Twitter / Google+ / Blogslovin and so on can use full resolution. I have also tried to trim the image (then I don’t have the problem with the editor and mail but is looks ugly in external use cases because of the low resolution).

    It’s possible that Jetpack’s image CDN is causing some troubles here. Would you please deactivate it so that we can see if that fixes this?

    To do that, go to Jetpack -> Settings -> Writing and deactivate “Serve images from our servers.”

    Then let’s see how the next email looks. Let me know how that goes 🙂

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Hi, I have checked that. It’s not the “serve images from our servers” feature which is causing the problem. The problem does only show up with individual size setting. If I change that to one of the standard sizes this problem does not show up. But then fixed aspects are cutting the pictures (which is not allowed for book covers).

    This is not only a problem with the mails but also in the editing view of the blog. Looks like this is not a jetpack problem but a general WordPress problem.

    This actually sounds like it might be related to your theme. Could you switch to Twenty Seventeen temporarily and then check this again? If the problem goes away, we can confirm it’s the theme. In that case, you’d want to contact the theme author directly and have them take a look.

    Let me know how that goes 🙂

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Hi, 2017 is my standard theme which I’m using when running into the problems. I have switchds to 2013 theme for testing purposes. In post editing it is working as it should – individial size is working. But when sending the mail it is still ignored with 2017 and 2013. Seems to be that mail is not linked to edit post design.

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi there, thank for trying that out!
    I have passed all the info to our developers so to check deeper on that 🙂

    I’ll keep you posted as soon as I have news to share, in the meantime let me know if there’s anything else we can do to help!

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi there! Sorry for the long wait, but I bring good news! Our developers have finally found the root of the issue and fixed it.

    You should be all set now! Can you double check for me, so to be extra sure that all is working okay from your end too? Thanks!

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Hi Stef,

    Thank you very much! Indiviual size is working now also in mails.

    What is still not working are galleries in mails. It is the same problem. Let’s say middle size is 250px the pictures in follower mails are not sized to this. I think they keep there original size but I’m not sure. But definately they don’t have the same size.

    If have created a test domain now which makes it easier to test without disturbing followers or spamming mails. 😉

    @torstensbuechereckede This is a known limitation of Tiled Galleries. In most cases the images don’t even appear, so if you’re seeing images there, we must be making progress.

    You can follow the issue here if you’d like:

    https://github.com/Automattic/jetpack/issues/1578

    I hope that helps!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Image resolution for follow on wordpress.com notification mails’ is closed to new replies.