Support » Fixing WordPress » Image resize doesn't work in WP 3.5

  • cjseattle

    (@cjseattle)


    I have a brand new install of WordPress 3.5 at dev.1000chefmarch.org. I have installed a theme and a custom child theme. There are no plugins installed yet. The issue I’m having is the same if I use theme Twenty Twelve, so this is not a theme issue.

    When I upload a photo, either inserting into post, setting a post thumbnail, or adding view Media->New, here’s what happens:

    1. The image loads to 100% (or in the case of inserting in a post, the gray progress bar goes to 100%). Then… either nothing else happens, or I get a generic HTTP error.

    2. The full size image is uploaded. I can go to the media library and see it has been uploaded.

    3. The smaller media sizes are not created. I am uploading images that are well within the size limit, and large enough in pixel dimensions to trigger creation of thumbnail, medium size, and large images. But no love.

    I have read that WP makes more use of ImageMagick if it is installed (don’t know if that’s true or not). So I had my host update ImageMagick to a recent version (the old one was from 2008).

    I managed to get one image to upload and have WordPress create the smaller image sizes, but then the next images (I tried a bunch to make sure it wasn’t a broken file of some kind)… none of them worked. Mostly getting HTTP errors now.

    I don’t really know what to do to troubleshoot. Should I ask host for error logs? The site has cPanel. The error logs in cPanel are empty, and raw access logs don’t look like they have anything useful.

    I had a possibly related issue with another site on the same server, and had to downgrade to 3.4.2. I hate to do that; when the heck will I ever be able to update?

Viewing 2 replies - 1 through 2 (of 2 total)
  • lecyril

    (@lecyril)

    Hi cjseattle,
    I can understand how you feel, I got the exact same symptoms after WP 3.5 upgrades (actually only jpg images were an issue, png or mp3 uploads were fine). It took me a while to narrow it down to ImageMagick with the help of a wordpress.org forum member, but in the end updating to ImageMagick 6.8.1-0 fixed everything. Can you create a phpinfo() file and see which version your host has upgraded to?

    For some reason, I still got a couple of upload errors after the ImageMagick upgrade, using another computer. I figured out that I needed to flush my browser cache because somehow this caused issues… Maybe because I use a caching plugin with Cloudflare services? Anyway, I hope this can also help you!

    cjseattle

    (@cjseattle)

    Thanks very much for the link and info. I’ve asked my host to upgrade to 6.8.1-0 specifically. They did, and unfortunately I still get an HTTP error when uploading jpgs. As you experienced, I am able to upload pngs, and they work fine.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Image resize doesn't work in WP 3.5’ is closed to new replies.