Support » Fixing WordPress » Image problems when emailing post

  • Resolved ellrond


    Hi there.

    Whenever I email an image to my blog it appears as a big piece of text.

    You can see it here:

    This is the second install on which I have had this problem, I removed the first install just in case it was an install error.

    Any help would be appreciated.


Viewing 5 replies - 1 through 5 (of 5 total)
  • For the image to display in a post it needs to be stored locally on your server and linked or needs to be pathed to a link where the image is stored externally. I presume you’re emailing your posts in from remote?

    Yes, I am posting both from my laptop and from my PDA.

    I was under the impression (and the Email Format section in the Blog by Email page in the codex – – supports it) that any images that are attached to the email would be saved to the server and posted inline?

    Is this not supposed to be the case? If not, please excuse me, but I was wondering if it could just be a case of screwed up MIME settings on my part.



    You could be right. I’ve tried it and have had similar problems. Perhaps you need to CHMOD your upload directory and change the permissions so the file can be saved?

    Thanks for your replies.

    As a test, I set CHMODded my uploads folder to 777, but this has had no effect.


    Fixed, kinda.

    Instead of using the built in email posting solution, use Postie. Works much better.


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Image problems when emailing post’ is closed to new replies.