WordPress.org

Forums

Ryu
Image posts with white background (5 posts)

  1. mindctrl
    Member
    Posted 1 year ago #

    If the theme chooses a white background for an image post, the text (title, meta, etc.) is also white and it can't be seen.

  2. Caroline Moore
    Member
    Posted 1 year ago #

    Howdy! Have you customized a child theme to force a white background for image posts? If so, you probably need to disable Tonesque support as well, since that's automatically calculating color contrast on the text in image posts.

    If that's not the case, can you please post a link to a site demonstrating the problem, so we can investigate further? Thanks.

  3. mindctrl
    Member
    Posted 1 year ago #

    Hey Caroline, thanks for the reply. I tested it using the default parent theme with no mods and it does the same thing. Although this link is using a slightly modified child theme, you can see an image here that gets a white background with Tonesque.

    I'd rather not disable Toneque, as I think it's pretty neat. :) It would be cool if the theme checked for a white background and adjusted the text color to a dark color. I notice on other colors it can flip to black, like it does here and here.

    I'm guessing that's a relatively easy fix, but I just haven't dug into it yet.

  4. Caroline Moore
    Member
    Posted 1 year ago #

    It would be cool if the theme checked for a white background and adjusted the text color to a dark color.

    That's part of what Tonesque does -- it adjusts the contrast automatically. It sounds like something is broken.

    In this case, from the link you posted, I can see the hex color code is missing a zero. This will not work, because it's not a valid hex code, so it defaults back to white:

    .post-1445.format-image {
        background-color: #72ca0;
    }

    This will work, and the resulting color appears to match the image color:

    .post-1445.format-image {
        background-color: #072ca0;
    }

    So at some point it looks like Tonesque or the theme is removing the preceding zero. Will dig a little deeper and let you know what I find. Thanks!

  5. mindctrl
    Member
    Posted 1 year ago #

    Good catch! I hadn't even looked close enough yet to figure that out. I was assuming the theme chose white because of the big white border on that pic, but is actually the blue with the missing zero. Teaches me once again about assuming. :)

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.