Support » Multisite » [Resolved] Image path issues and confusion

[Resolved] Image path issues and confusion

  • OK, maybe it was my old profile? I can’t seem to post anything here without triggering spam filters and locking the thread. Maybe someone can actually reply to this one…fortunately, I found another login I used to use!
    I have my main site and one add-on site up and running on multisite. Today I had a major issue come up with a third site and the host admin ended up pretty much wiping the install directory, so I decided it would be a great time to go ahead and migrate this third site into my multisite install.

    So far, after lots of SQL insanity, I seem to have managed to get the main content back up and running. But when I went to put my old original header image back up, I just hit a brick wall. Here are what I believe are the relevant image path settings as they stand right now:

    Uploads Use Yearmonth Folders = 0
    Upload Path = wp-content/blogs.dir/3/files
    Upload Url Path = site3/wp-content/blogs.dir/3/files
    Fileupload Url = site3/wp-content/blogs.dir/3/files

    When I attempt to upload a new header image, it is broken. WordPress is trying to assign it this URL: site3/files/cropped-Server+Room2.jpg

    htaccess contains the following:


    Any ideas?

Viewing 15 replies - 1 through 15 (of 51 total)
  • also, I’m using the subdirectory version of this, not subdomain (if that helps)

    I just upgraded to 3.3 yesterday, and all images are broken (except for a few offiste ones that were directly linked to). I’m not using any image plug-in, either. Headers, article images are all broken.

    Oh so it’s not just me…as bad as it may seem it’s comforting to know I’m not the only one having problems with this.

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Um… http://wordpress.org/support/topic/image-path-issues?replies=2 is the exact same post.

    Are these BOTH you?

    Yes. As soon as I posted my first post the thread was locked. I’m guessing from either too many links or lines of code? Also, there is a possibility that my user profile was flagged or something. After I changed the password on THIS User profile (dixonge) I was able to use it to post without getting locked down immediately….

    But – if the other one is unlocked now, I guess I’ll answer over there?

    ok, so now the other thread is locked, I guess I’ll continue here!

    I’m using subfolders.

    I have ended up changing ten different parameters, including the Fileupload Url, in ten different ways. None of the combinations has worked so far.

    Each time I make a change I test it by attempting to upload a new header image. So far the result is that the new image is immediately broken, because it is being uploaded to one location but all references to it are looking for it in another location. This is even true for the Media Library. All images, past and present, are broken.

    My Fileupload Url currently matches what you wrote: http://site3/files

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    What’s the location it’s looking in?

    It’s SUPPOSED to look in domain.com/site3/files/2011/12/image.jpg

    Yes, I know it’s not there, don’t worry about that. If it’s looking THERE then the most likely issue is that your server isn’t reading your .htaccess correctly and needs AllowOverride set to All in yout httpd.conf

    I’m not sure I understand the question. “looking in” ?

    In my first post I mentioned that WordPress is trying to assign it this URL:


    Is this what you mean?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Yeah- OH!

    Uploads Use Yearmonth Folders = 0

    Why is that a 0? Make that 1.

    I was trying everything!

    ok, changed it to a 1 – it’s now looking for the images in:


    but the image is actually being uploaded to:


    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Okay, lesson time 🙂

    It’s supposed to look in site3/files/2011/12/image.jpg

    Go look at your .htaccess

    See RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    It translates that URL to site3/wp-content/blogs.dir/3/files/image.jpg … Actually it should translate to site3/wp-content/blogs.dir/3/files/2011/12/image.jpg but with all the mucking around you did…

    What happens if you go to site3/wp-includes/ms-files.php?file=/2011/12/image.jpg

    my .htaccess does contain that line

    tried the ms-files.php URL – 404 error

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    How about … domain.com/wp-includes/ms-files.php?file=/2011/12/image.jpg

    Notice how I REMOVED site3 from that URL?

    I do think the problem is your httpd.conf file isn’t set up right and needs AllowOverride set to All.

    nope, that didn’t work either.

    You keep mentioning httpd.conf – I’m on a shared hosting account. I don’t think I have access to that directly, unless it is in cPanel…

    Here is the kicker. I know where my existing image files are. How tha heck do I tell MultiSite how to find and reference them? Which settings affect that?

    Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Stop trying to ‘tell’ Multisite anything, that’s how you got all this screwed up worse in the first place. Multisite already KNOWS what it’s doing. It KNOWS that site3/files/2011/12/etc means /blogs.dir/3/files/2011/12/etc – It’s very smart 🙂 The ms-files.php file and the .htaccess are how it knows. The more you mess with that, without understand how it works, the worse off you are.

    Go tell your host that you need THEM to check their httpd.conf and see if AllowOverride is set to ALL, because you have .htaccess rules not being read.

    (Also set your blogs.dir folder, and all children folders to either permission 775 or 777 while you’re at it, I’ve seen weirder.)

Viewing 15 replies - 1 through 15 (of 51 total)
  • The topic ‘[Resolved] Image path issues and confusion’ is closed to new replies.