Support » Plugin: LiteSpeed Cache » image optimize not working

  • Resolved horrormovies.gr

    (@horrormoviesgr)


    Hello, when i press Image Optimization Initialize Optimization to start it says:
    “IAPI Error A valid URL was not provided.”

    I used debug log if it is helpful:

    01/30/20 13:47:45.551 [79.129.37.76:63250 1 aZ1] 💓 ——GET HTTP/1.1 (HTTPS) /wp-admin/admin.php
    01/30/20 13:47:45.551 [79.129.37.76:63250 1 aZ1] Query String: page=lscache-optimization&LSCWP_CTRL=img_optm&LSCWP_NONCE=6969c39c26&type=sync_data
    01/30/20 13:47:45.551 [79.129.37.76:63250 1 aZ1] HTTP_REFERER: https://horrormovies.gr/wp-admin/admin.php?page=lscache-optimization
    01/30/20 13:47:45.551 [79.129.37.76:63250 1 aZ1] Cookie _lscache_vary: admin_bar:1;logged-in:1;role:99
    01/30/20 13:47:46.373 [79.129.37.76:63250 1 aZ1] [Ctrl] X Cache_control -> no Cache ( logged in user )
    01/30/20 13:47:46.423 [79.129.37.76:63250 1 aZ1] [Router] LSCWP_CTRL: img_optm
    01/30/20 13:47:46.423 [79.129.37.76:63250 1 aZ1] [Router] LSCWP_CTRL verified: ‘img_optm’
    01/30/20 13:47:46.423 [79.129.37.76:63250 1 aZ1] [Router] parsed type: sync_data
    01/30/20 13:47:46.424 [79.129.37.76:63250 1 aZ1] [IAPI] posting to : https://wp.api.litespeedtech.com/list_clouds
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] us.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] eu.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] as.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [IAPI] failed to ping all clouds
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [IAPI] req auth_key
    01/30/20 13:47:47.274 [79.129.37.76:63250 1 aZ1] [IAPI] posting to : /request_key
    01/30/20 13:47:47.274 [79.129.37.76:63250 1 aZ1] [IAPI] failed to post: A valid URL was not provided.
    01/30/20 13:47:47.274 [79.129.37.76:63250 1 aZ1] [IAPI] request key failed: — ‘A valid URL was not provided.’
    01/30/20 13:47:47.276 [79.129.37.76:63250 1 aZ1] [IAPI] posting to : /media_sync_data
    01/30/20 13:47:47.276 [79.129.37.76:63250 1 aZ1] [IAPI] failed to post: A valid URL was not provided.
    01/30/20 13:47:47.276 [79.129.37.76:63250 1 aZ1] [Ctrl] 301 from https://horrormovies.gr/wp-admin/admin.php
    01/30/20 13:47:47.276 [79.129.37.76:63250 1 aZ1] [Ctrl] 301 to https://horrormovies.gr/wp-admin/admin.php?page=lscache-optimization&type=sync_data
    01/30/20 13:47:47.277 [79.129.37.76:63250 1 aZ1] [Ctrl] X Cache_control -> no Cache ( 301 to same url )
    01/30/20 13:47:47.278 [79.129.37.76:63250 1 aZ1] [Ctrl] not cacheable before ctrl finalize
    01/30/20 13:47:47.278 [79.129.37.76:63250 1 aZ1] [Router] get_uid: 1
    01/30/20 13:47:47.278 [79.129.37.76:63250 1 aZ1] [Router] get_role: administrator
    01/30/20 13:47:47.279 [79.129.37.76:63250 1 aZ1] X-LiteSpeed-Cache-Control: no-cache
    01/30/20 13:47:47.279 [79.129.37.76:63250 1 aZ1] [Optm] bypass: Not frontend HTML type
    01/30/20 13:47:47.279 [79.129.37.76:63250 1 aZ1] End response
    ——————————————————————————–

    01/30/20 13:47:47.597 [79.129.37.76:10104 1 0Xs] 💓 ——GET HTTP/1.1 (HTTPS) /wp-admin/admin.php
    01/30/20 13:47:47.597 [79.129.37.76:10104 1 0Xs] Query String: page=lscache-optimization&type=sync_data
    01/30/20 13:47:47.597 [79.129.37.76:10104 1 0Xs] HTTP_REFERER: https://horrormovies.gr/wp-admin/admin.php?page=lscache-optimization
    01/30/20 13:47:47.597 [79.129.37.76:10104 1 0Xs] Cookie _lscache_vary: admin_bar:1;logged-in:1;role:99
    01/30/20 13:47:48.394 [79.129.37.76:10104 1 0Xs] [Ctrl] X Cache_control -> no Cache ( logged in user )
    01/30/20 13:47:48.490 [79.129.37.76:10104 1 0Xs] [Ctrl] X Cache_control -> no Cache ( Admin page )
    01/30/20 13:47:48.545 [79.129.37.76:10104 1 0Xs] [Ctrl] not cacheable before ctrl finalize
    01/30/20 13:47:48.545 [79.129.37.76:10104 1 0Xs] [Router] get_uid: 1
    01/30/20 13:47:48.545 [79.129.37.76:10104 1 0Xs] [Router] get_role: administrator
    01/30/20 13:47:48.546 [79.129.37.76:10104 1 0Xs] X-LiteSpeed-Cache-Control: no-cache
    01/30/20 13:47:48.546 [79.129.37.76:10104 1 0Xs] [Optm] bypass: Not frontend HTML type
    01/30/20 13:47:48.546 [79.129.37.76:10104 1 0Xs] End response
    ——————————————————————————–

    01/30/20 13:48:46.242 [79.129.37.76:40078 1 E0X] 💓 ——GET HTTP/1.1 (HTTPS) /wp-admin/admin.php
    01/30/20 13:48:46.242 [79.129.37.76:40078 1 E0X] Query String: page=lscache-debug
    01/30/20 13:48:46.242 [79.129.37.76:40078 1 E0X] HTTP_REFERER: https://horrormovies.gr/wp-admin/admin.php?page=lscache-optimization&type=sync_data
    01/30/20 13:48:46.242 [79.129.37.76:40078 1 E0X] Cookie _lscache_vary: admin_bar:1;logged-in:1;role:99
    01/30/20 13:48:47.194 [79.129.37.76:40078 1 E0X] [Ctrl] X Cache_control -> no Cache ( logged in user )
    01/30/20 13:48:47.294 [79.129.37.76:40078 1 E0X] [Ctrl] X Cache_control -> no Cache ( Admin page )

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] us.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] eu.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [Util] ping [Domain] as.wp.api.litespeedtech.com [Speed] 99999
    01/30/20 13:47:47.243 [79.129.37.76:63250 1 aZ1] [IAPI] failed to ping all clouds

    It seems all the ping are timed out.

    Please check if you have any firewall , and if so , please add our IPs to whitelist

    Also please try click “reset IAPI key”

    Best regards,

    Hi, i added the whitelist rule on cloudflare but nothing changed. This is the only i guess firewall.
    I cannot find also an option “reset IAPI key”.

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Could you please provide the report number ?

    Best regards,

    IEUDSJLF

    Hi @horrormoviesgr, can you try to make a simple PHP curl request like:

    <?php
    $ch = curl_init();
    curl_setopt($ch, CURLOPT_URL,"https://eu.wp.api.litespeedtech.com");
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
    $server_output = curl_exec($ch);
    curl_close ($ch);
    print_r($server_output);

    to see does it also show timeout?

    Hello, i did it and it shows quickly the message:
    “Hello from LiteSpeed Cloud Server 185.29.24.7”

    Could you try the following script for testing the ping function?

    <?php
    
    $domain = 'us.wp.api.litespeedtech.com' ;
    $starttime	= microtime( true ) ;
    $file		= fsockopen( $domain, 80, $errno, $errstr, 10 ) ;
    $stoptime	= microtime( true ) ;
    $status		= 0 ;
    
    if ( ! $file ) {
    	echo "---Ping error–--" ;
    	echo "\r\n" ;
    	echo $errno ;
    	echo "\r\n" ;
    	echo $errstr ;
    } else {
    	fclose( $file ) ;
    	$status = ( $stoptime - $starttime ) * 1000 ;
    	$status = floor( $status ) ;
    	print_r( $status );
    }

    It gives me:
    “Hello from LiteSpeed Cloud Server 185.29.24.7” —Ping error––

    The test url is https://horrormovies.gr/vasilis2.php

    Seems your hosting provider disabled the fsockopen function or firewalled outbound requests, please contact them about this question with your testing script to confirm the function is enabled.

    Yes, they confirm that fsockopen is disabled but they said that they couldn’t enable it for security reasons.

    As we have different optimization server worldwide so we need fsockopen function to get the closest location. So please try to migrate to a server that supports this function.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘image optimize not working’ is closed to new replies.