Support » Fixing WordPress » Image Not Uploading in Custom Community

  • Resolved ceux


    I installed wordpress last week and started building my website using Custom Community. Originally, I was able to upload a photo to my header in addition to the logo I uploaded. Then I wanted to change the photo so I deleted it and since then I have not been able to upload a photo to the header. The header still shows the logo I uploaded but now also shows default Custom Community header behind it. If I go to upload header image, I can click it, make photo selection, and click insert, but the image does not load and I don’t receive any sort of error message. I have tried inserting the previous image as well as different sized images and still nothing. Then I tried uploading favicon image and the same thing happened…nothing. So I’m wondering if it’s something in the theme settings? I can upload images to posts and pages with no problem. I have tried uploading images after enabling and disabling custom header settings, have deactivated a file gallery widget I use in case that was somehow interfering, cleared out image cache, tried to find code relating to header image in Editor mode (both under Header and Style sheet) but didn’t see anything that I could manually alter. I’m at a lost and not that advanced with wordpress. Any advice? My website isn’t done yet so I’m not bothering to include the address. Many thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi ceux,

    To test if this is an issue with the theme I would suggest changing to the default theme and seeing if you can upload a header image with the default theme. If that works, you may need to remove and re-install your theme.

    Hope this helps!

    Thanks! Picture did load with default theme. Question though: I switched themes in order to do it…wasn’t given option to deactivate current theme of Custom Community first. Now I only see option to install it again. Would that be enough or how do I go about removing it first? Under themes it doesn’t even appear in the Installed Themes section. Thanks for you help:)

    Hello again ceux,

    Sounds like something happened with that theme. I would recommend re-installing it. If you have any trouble with that, make sure that the folder is not still there under wp-content/themes. If it is, rename that theme’s folder and you should be able to re-install then.

    Let me know if this works.


    I did all of the above–deleted theme, re-installed, tried uploading images again. Still same problem. Though I noticed that upon re-installing, under Appearance settings in Dashboard sidebar, Header now appears. This is something that was initially there last time I installed but had disappeared from sidebar when started having problems. Tried doing it in Safari as well (have been using Firefox) but same problem. So I’m completely stuck and now back at zero. Also, this might just be weird coincidence but since I’ve been having this problem I’ve noticed that the WordPress favicon has disappeared when I load my dashboard page (unlike here where I can see the W). I really don’t know what to do as this theme is best suited for my needs.

    Hello again ceux,

    This is really puzzling as I tried out that theme with no issues. What version of WordPress are you running? Make sure that there are no compatibility issues between your WordPress version and the theme.

    If all else fails, you may want to do a fresh install of WordPress in case something has been accidentally deleted or gotten corrupted with your files. Of course you will want to backup your files before doing that so you have a copy of your site.

    Problem solved. By trying other things when loading image I clicked on file image button to load that url and then clicked insert image to post. And that worked! Seems so simple but not obvious since one of the options for url is none (which I hadn’t clicked but I guess was the default setting). I thought that option was for if you wanted your image to link to another source–which I didn’t since it was a header image. So all seems well now! Thanks again for all your help.

    Take care,

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Image Not Uploading in Custom Community’ is closed to new replies.