Support » Fixing WordPress » Image not uploaded or inserted into post

  • Resolved richardpd

    (@richardpd)


    I uploaded an image today to media library and all seems to have worked normally except the thumbnail is blank (greybox) and my image does not display in my post!
    The post is at:
    http://richard-dickinson.com/2017/04/06/inspiration/
    This is rather annoying, why a simple image upload and insert to post doesn’t work now.
    Anyone any bright ideas for an easy quick fix?
    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi @richardpd,

    I looked at your post. Thanks for including the link.

    I think this is the filename of the image that isn’t loading.

    rpd_N-Mandela-Do-not-judge-me-by-success-but…-300×129.png

    I would change the filename so it is much shorter and remove any periods other than the .ping. Something like

    mandela_judge_me_quote.png

    Upload and insert the new one and see if it works.

    Best,
    mark

    Thanks for your helpful reply Mark.

    I have renamed the file and it displays properly now.
    I left a comment about this on my post:
    07/04/17
    I asked in WP forum for help with this media library image not displaying and
    received a helpful reply from a mark chaves, who suggested renaming the file also…Thanks Mark.
    So I tried renaming my file to remove an underscore and trailing periods
    and the renamed image uploaded successfully!
    (rpd_N Mandela Do not judge me by success but…png, renamed to, N Mandela Do not judge me by success but.png and this renamed image uploaded successfully).
    See this image of the media library (this shows the uploaded image thumbnail alongside the non uploaded, non displaying image thumbnail).
    WP media library N Mandela image upload issue

    Issue fixed…so my advice is same as Mark’s..try not to use extra characters in image file names! I do not know the exact image upload naming rules but this seemed to be the problem.
    Happy WordPressing!

    All fixed now..thanks 🙂

    Excellent! Great job, @richardpd. 🙂
    -m

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image not uploaded or inserted into post’ is closed to new replies.