• Resolved sidddddddd

    (@sidddddddd)


    Hi there,

    Since today i’m having issues with the generation of PDF invoices. All images (logo and products) give an error of; Image not found or type unkown. This only occurs in the generated PDF file. In the preview browser window I can see the logo without a problem.

    Creating an new template doesn’t solve this issue. There weren’t any updates performed on the server.

    Hope someone can assist.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter sidddddddd

    (@sidddddddd)

    An update. When I change the logo URL from HTTPS to HTTP than it shows the logo, but the products still aren’t visible and I would like to only use HTTPS.

    UmbrellaWeb

    (@umbrellaweb)

    Also getting the same issue.

    Changing HTTPS to HTTP doesnt have any effect fo us. Its the same regardles of the protocol used: Image not found or type unkown

    Thread Starter sidddddddd

    (@sidddddddd)

    Since when do you have this problem? Also since a few days?

    yup. been trying to figure it out with no success…

    Thread Starter sidddddddd

    (@sidddddddd)

    Do you use the Let’s Encrypt plugin?

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    Moderator note:

    @umbrellaweb, If you need support then per the forum guidelines please start your own topic.

    A lot more people will see your post, and that way you stand a good chance of getting the assistance you want. Despite any similarity in symptoms, your issue is likely to be completely different because of possible differences in physical servers, accounts, hosts, plugins, theme, configurations, etc. Thus one problem, on one setup is not indicative of the functionality and reliability of an application as a whole.

    Frequently Asked Questions

    Forum Guidelines

    You can do so here:

    https://wordpress.org/support/plugin/print-invoices-packing-slip-labels-for-woocommerce//#new-post

    Thanks.

    Plugin Author webtoffee

    (@webtoffee)

    Hi @sidddddddd,

    Thanks for reaching out.

    Kindly go through this article and follow the steps to fix the images/logo missing issue on the PDF documents.

    Thread Starter sidddddddd

    (@sidddddddd)

    Hi webtoffee,

    Thank you for your answer. I saw this document en tried al the steps

    Imagick and GD are both present. The image permissions and size are OK. I know this because the image display’s on other parts of the site. And also when I change the logo in the plugin from https://….. to http://

    I’ve also tried the code snippet by creating a new snippet for running on all parts of the site, but this also hasn’t had any effect unfortunatly.

    Plugin Author webtoffee

    (@webtoffee)

    Hi @sidddddddd,

    Thanks for sharing the information. Could you please try installing our mPDF addon and see if the issue persists.

    Once installed, go to Invoice/Packing > General Settings > PDF library and choose mpdf. Then try downloading an invoice and see if the error persists.

    Note: Please make sure that the above-mentioned code snippet is also active.

    Thread Starter sidddddddd

    (@sidddddddd)

    Hi,

    Thank you. I’ve also tried that but it didn’t solve anything. But the problem is now solved. I already suspected it was something with HTTPS but couldn’t wrap my head around it. I’ve removed the WP Encrypt plugin and removed the free Let’s encrypt plugin and installed a new one and now it works.

    I’ve done this because there were some browsers that we’re having issues with my website. They were giving certificate expired notifications, this because of an expired Root CA with let’s encrypt. Maybe the issue with the PDF Invoice plugin is related to this problem.

    Anyway, happy that it works again.

    Thanks for the support.

    Plugin Author webtoffee

    (@webtoffee)

    Hi @sidddddddd,

    Great job! We appreciate your effort. We are marking this thread as Resolved since the issue is resolved. Please feel free to open a new thread or follow-up if you have any further questions or need any help.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.