Support » Plugin: Send Images to RSS » Image not appearing in feed for Mailchimp

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Robin Cornett

    (@littlerchicken)

    Hey Brad! Looking at your feed, I think my plugin is not the one you need, as it converts images that are actually in your post content and changes them for email. It looks to me like what you want is a plugin which will render the featured image, probably with your RSS feed excerpt, rather than your full content output. I actually wrote a blog post with code which I would recommend using to accomplish this, because your situation is pretty common.

    If you are OK with editing your theme’s functions.php file, that’s the approach I would recommend you take, and not use this plugin. If you’re not comfortable with mucking around with the code, look at using the plugin I referenced in the post, or a similar one, which will accomplish what you want.

    Hope that helps and good luck!

    Thanks for the quick reply Robin.

    I removed your plugin and added the one you recommended. I didn’t add the code to functions.php though as I didn;t think that applied to me. My merge code is in a column for the image so it works with Outlook.

    Anyhow, I can see in the feed it’s changed to resize it to 150×150:
    http://www.primalhealth.co/feed

    It doesn’t reflect this in Mailchimp though:
    http://i.imgur.com/e2wo5kt.png

    I hoping by waiting a day this may change as this has happened to me the other day when I was trying to fix a similar plugin change the other day on another site.

    Do you have any other suggestions? Appreciate your time!

    Brad

    Plugin Author Robin Cornett

    (@littlerchicken)

    Brad, you are right in that it sometimes takes time for RSS feeds to update (and right that you do not want both the plugin and the code from my post). However, since the image is showing in the MailChimp preview, I think you have something else going on. My guess is that you’re using the Jetpack Photon module, which resizes your images more or less on the fly (among other things), which is great, except when you’re working with an RSS feed, especially when you’re dealing with an email client like Outlook. What you need is for the website generated thumbnail image to be sent to the RSS feed, and Photon prevents that from happening (it sends a version which is cropped and resized using javascript, or magic).

    I don’t know how attached you are to the Photon module, but I would suggest disabling that. You can keep everything else in Jetpack, but unless you want to dig in and do some more code in your functions file, I think disabling the Photon module is your safest bet. Hope that helps.

    Hey Robin

    I went straight to Mailchimp first to see what propogated and it looked like this: http://i.imgur.com/tmLH149.png

    So I deactivated your recommended plugin again, and reactivated the WP RSS Images one I originally had. Now it looks like this again:
    http://i.imgur.com/TOYiLPU.png

    I’ve turned off Photon, delete my WP SUper Cache and it still looks the same. I’ll wait another day to see if it changes as the resize code looks correct wouldn;t you think?
    http://primalhealth.co/feed/

    Thanks Robin for your help. Legendary status in my book 🙂

    Brad

    Plugin Author Robin Cornett

    (@littlerchicken)

    So, it looks to me like the newer plugin worked, but with no alignment applied to the image, and not using the column you have created, hence the big blank space. The older plugin appears to also work, and puts the image in the column, but something in the email’s raw code is preventing everything from lining up. I think you need to switch to the raw code view of your email and dig into that, see why the column is misbehaving.

    Woo hoo! It worked. Just checked back in. So long to work this out. Photon was the problem!

    Thanks a heap Robin. Saved me lots more time and headache!

    Brad

    Plugin Author Robin Cornett

    (@littlerchicken)

    Glad you got it sorted, Brad!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Image not appearing in feed for Mailchimp’ is closed to new replies.