WP Smush
[resolved] Image must be within the website home URL (7 posts)

  1. Pietro Gregorini
    Posted 1 year ago #

    I know that other people are experiencing a similar problem.
    When I try to Smush my images, I got an error saying:

    ERROR: http://www.mywebsite.com/assets/media/2013/09/myimage.jpg must be within the website home URL (http://www.positive-magazine.com/mywordpressfolder)

    For security reasons I use a secret folder inside my server for all the WordPress files, while using an outside folder (assets) for uploads of media files. Unfortunately Smash.It can't do its work due to this reason.

    Is there any fix coming someday? I experienced this thing many months ago yet when I first tried the plugin.



  2. Bobby
    Posted 1 year ago #

    Try rolling back to version 1.6.5.

  3. Pietro Gregorini
    Posted 1 year ago #

    It doesn't work anyway.

    /web/htdocs/www.domain.com/home/assets/media/2013/09/myimage.jpg must be within the content directory (/web/htdocs/www.domain.com/home/assets/media)

    Uhm... What else could I try?

  4. @Pietro Gregorini,

    You can please try this beta of Smush.it https://dl.dropboxusercontent.com/u/2616987/WPMUDev/wp-smushit/beta/wp-smushit-

    Once installed go to the Settings > Media page and look for the Smush.it section. You will see a new checkbox to turn off the enforce same URL check. Then try either Bulk Smush.it or individual.

    This may not work depending on your setup.

  5. dangcreations
    Posted 1 year ago #

    Been looking for a fix for this for days! That beta is working so far, lets hope nothing breaks. Thank you!

  6. Hi there @dangcreations

    That's great news, glad to here the beta is working for you :)

    Have a great day!

    Kind Regards

  7. Just released WP Smush.it which includes the beta and some other small changes.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Smush
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.