Support » Fixing WordPress » Image Loader Not Working – 3.3.1

  • Resolved cynwulfdesign


    I am having issues since upgrading to version 3.3.1 with the image loader not working properly. I have cleared the browser cache, deactivated all plugins, switched from my Stealth theme to TwentyEleven, and had the server host reboot the server. But thus far the problem continues.

    The issue appears to be that the images are getting onto the server, but the metadata is not getting stored in the wordpress database. Thus the Media Library shows no record of the images being available.

    Can someone give me some options? Otherwise, I’ll have to reinstall an older version to get this working again.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I am having issues too. it seems to work intermittently for me. Sometimes I can upload a photo, sometimes not. lately it will upload, 56% or so and just stop. When I go back to the browser uploader it’s the same issue, intermittent success.

    I’m having the same issues with 3.1 & 3.3.1 on multiple browsers/machines.

    Also, my rich text editor icons don’t display. I get the little boxes but with no icons. WP seems to be having problems with all images. They won’t show in my Dashboard OR on my site.

    Issue still not resolved.



    Forum Moderator

    This is a fix for version 2.5 from 3 years ago.

    I’ll try the underlying corrective measures described here. But I think a 3.3.1 version of this support topic is clearly in order. Why would someone follow a remedy for 2.5 when they are running a much later version.

    Also, it would be very good to figure out why this occurs through using the established automatic upgrade process. In my case, no errors are being posted so I haven’t a clue what code inside WordPress is causing the problem.

    I cleaned out the root folder for WordPress, the wp-admin and wp-includes folders (including all subfolder content) and then uploaded the files from the wordpress3.3.1 zip file for those folders. And I emptied my browser cache and restarted the browser.

    I am still having the same issue…
    I try to upload a file and the wp-admin/upload.php just continues to run and run with the “crunching” message sitting up on the screen. I’ve tried different file types, sizes and names. The host says, the files get on the server, but the metadata does not get entered into the database for the Media Library to know its there.

    Now the question is “how” do I determine what the upload.php code module is stuck on? Which line of code? Or even see the error it’s running into?

    [sig moderated as per the Forum Rules]



    Forum Moderator

    Have you tried checking the server’s error logs?

    Nothing has appeared relating to this in the error or access logs. Even the host is stumped.



    Forum Moderator

    Are the images being uploaded to the correct folder in wp-content? Is your host running the latest version of GD Library?

    What is the correct folder in wp-content? The images are currently being uploaded to the wp-content/uploads/2012/01 folder.

    The GD Library information is as follows…
    GD Support enabled
    GD Version bundled (2.0.34 compatible)
    FreeType Support enabled
    FreeType Linkage with freetype
    FreeType Version 2.1.3
    GIF Read Support enabled
    GIF Create Support enabled
    JPEG Support enabled
    libJPEG Version 6b
    PNG Support enabled
    libPNG Version 1.2.5
    WBMP Support enabled
    XBM Support enabled



    Forum Moderator

    The uploads folder is correct and the GD Library sounds OK. Can you try uploading one of the header images that was packaged with Twenty Eleven?

    I tried that and it uploads the image, starts “crunching” the image and that message stays on the upload screen. I click on “save all changes” and check the Media Library. There are no new images present.

    I took the time to investigate the database version and I noticed that it was still showing it’s version as “17056” (WP31). So I went and downloaded and manually installed version 3.1.1, 3.2, 3.3 and 3.3.1. Then I proceeded to allow the database to be “upgraded” after each install when I logged in . But for some reason even after going through all that the database version still displays “17056” even though the install process says it upgraded the database each time.

    I tried the image loader again after all that was done and it still is failing to upload images. I really can’t imagine what could be the issue here. Next step is the blow away the database and start from scratch but that is not appealing.



    I’m experiencing a similar problem.

    It seems random – plenty of files upload without any problem, then I try to upload more and it sticks – sometimes partway through the upload process, and sometimes showing 100% uploaded, but failing to continue on to the ‘crunching’ stage. What I’ve found is that attempting to upload the same file again doesn’t work. But uploading a different file generally works fine – and then if I go back to the stuck file, and retry that, it uploads no problem.

    Hey esmi!
    I am still having the image uploader issue. I’ve tested some things out and oddly enough my other wordpress site at version 3.2 is working just fine on another server. So I contacted my host and had the one site that wasn’t working properly moved over to the same server and asked them to verify the security on the folders was exactly the same as the wordpress site that was working. (both are now at version 3.2)

    But no change. The freshly moved site that has had all of it’s code reloaded at the 3.2 version still doesn’t upload images properly.

    Now what it DOES do is something I wanted to ask you about. Perhaps this will shed some light on the reason why it fails.
    – It does upload the original to the proper Upload subfolder.
    – What it doesn’t do is create any thumbnails.

    Now if the database metadata on the images is stored after the thumbnails get created that might be the reason this never gets done.

    I would like to know “in what order does the upload.php process the images?”
    And “what could be causing the thumbnail creation code (wherever that is) to fail?”


    Well I finally resolved the problem.. the hard way.

    I figure it was something to do with either the content folder or the database. I blew away those two things and installed 3.3 clean. No issues on the same host server. Go Figure!

    I really hate, as a developer, leaving bugs behind. But I’ve spun my tires long enough on this one.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Image Loader Not Working – 3.3.1’ is closed to new replies.