Support » Plugin: NextGEN Custom Fields » Image Links Disabled After WP 3.5 Upgrade

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author shauno

    (@shauno)

    Hi Lynn
    Have you upgraded ngg too? If you upgrade ngg it will overwrite the template changes you made to get the links working.

    Hi Shauno –
    No, I hadn’t upgraded NGG until the problem occurred… only then did I upgrade to see if that was the problem. I did in the meantime find a workaround using the “alt” field, but the custom field no longer works.
    Thanks for your speedy reply!
    Lynn

    Plugin Author shauno

    (@shauno)

    Hmm, strange. It has been tested with 3.5. I am on holiday at the moment, so I don’t have my dev machine to check with. I will be back this weekend and I will see if we can work out the problem.

    Thanks so much, Shauno…. enjoy your holiday!

    Plugin Author shauno

    (@shauno)

    Hi again Lynn

    I’m finally back home in front of my dev machine, so let’s see if we can figure out what’s happening with your custom fields. Firstly, just be sure everything is up to date, although it sounds like it is (WP 3.5, NGG 1.9.10, NGGCF 1.2.2).

    Do the custom fields still show up fine in the backend when managing a gallery? And then can you change and save them successfully?
    If all that works fine, then what [shortcode] are you using to display the gallery in the page/post? Once I know that, we can start debugging the template.

    Hi again, Shauno –

    Thanks so much for getting back to me… yes, everything is updated. The custom fields still show up under “Manage Gallery”, but do not function as they used to before the upgrade.

    Here is the shortcode I was using: [nggallery id=17 template=caption]
    In order to work around the problem, I am now using this: [nggallery id=17 template=caption template=link] which enables me to put the custom link in the Alt text field.

    I really appreciate your follow-through on this!

    Lynn

    Plugin Author shauno

    (@shauno)

    When you add the template=caption to the shortcode, it means that NGG will use the gallery-caption.php template in the nextgen-gallery/views/ directory. Adding 2 instances of template= might behave funny. I’m not sure which template it will use.
    Let’s try debug the caption template to start with.

    So, change the shortcode back to [nggallery id=17 template=caption]. Now, what does the code around the link in gallery-caption.php template look like? Can you post the whole <a> tag here (don’t forget to put it in code tags so it formats for the forum).

    If I’m jumping ahead or going too fast let me know, I’m not sure what level WP user you are 🙂

    Plugin Author shauno

    (@shauno)

    You need to put the code in backticks so it formats for the forum. You can click the "code" button above to open and close the backticks

    imageURL ?>" title="<?php echo $image->description ?>" <?php echo $image->thumbcode ?> >
    <?php if ( !$image->hidden ) { ?>
    <img title="<?php echo $image->alttext ?>" alt="<?php echo $image->alttext ?>" src="<?php echo $image->thumbnailURL ?>" <?php echo $image->size ?> />
    <?php } ?>

    Sorry… was in too big a hurry last night….:-(

    Plugin Author shauno

    (@shauno)

    I still don’t see the start of the <a> tag nicely, or the closing </a>? Perhaps you can just copy and paste the entire contents of the file to Pastebin.

    Plugin Author shauno

    (@shauno)

    Hi Lynn
    Did you get this figured out? I’m marking this thread as resolved for now. If you still need help please let me know.

    Hi Shauno,
    Unfortunately, no…. I’m still using the [template=caption template=link]shortcode. It works that way, and I haven’t had the time to probe further, other than what we’ve discussed here.

    Thanks so much for following up!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Image Links Disabled After WP 3.5 Upgrade’ is closed to new replies.