Support » Plugin: Pixel Caffeine » Image Link Url Incorrectly Formatted

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Antonino Scarf√¨

    (@antoscarface)

    Hi,

    the issue seems to be specifically here (for each item):

    
    <g:image_link>
    data:image/png;base64,iVBORw0KGg...
    </g:image_link>
    

    First off, make sure you are using the latest version of the plugin 2.1.0, because I fixed the exact same issue for who using SG Optimizer. If you are using this plugin, it will be fixed with 2.1.0 of Pixel Caffeine.

    Otherwise, try to deactivate all plugins and check the product catalog by refreshing it manually: if it will work without any problem, there is a plugin that created this issue.

    If so, then activate all plugins back one by one, checking the product catalog refreshing, in order to discover which plugin created the issue.

    You can do the same operation easily thanks to this plugin if you want: https://wordpress.org/plugins/health-check/ (it’s inside WordPress since 5.2).

    Yes, I’m using SG optimizer, so you have a hotfix I can download?

    Plugin Author Antonino Scarfì

    (@antoscarface)

    The fix is already inside the latest version of Pixel Caffeine. Make sure you have upgraded the plugin correctly.

    atrain009

    (@atrain009)

    The plugin is 2.1.0, but the error is still happening. Would you like site access to take a look?

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    unfortunately, I cannot get the site access.

    Anyway, you can try to re-install the latest version of the Pixel Caffeine plugin, in order to make sure that any issue occurred during the upgrade.

    Then, could you please share the screenshot of the configuration panel of SG Optimizer? In order to replicate your configuration on my end and check.

    Thanks.

    atrain009

    (@atrain009)

    Reinstalled, issue still occurring. See settings below.

    https://imgur.com/a/CkeoPqD

    Plugin Author Antonino Scarfì

    (@antoscarface)

    Uhm, you shouldn’t have this problem anyway because I see the optimize image from SG Optimizer is disabled.

    However, I found it that the issue is occurring (at least for me) only when the lazy loading images is enabled and during the cron job. Unfortunately, I cannot find any solution to this issue from my side because the optimizer is triggered before that Pixel Caffeine is loaded.

    So, the only way to solve this is from the Siteground plugin code, by asking to the developer.

    The solution should be to add a check inside the method filter_html of the class SiteGround_Optimizer\Lazy_Load_Images\Lazy_Load_Images.

    Now, there is this:

    
    // Bail if it's feed or if the content is empty.
    if (
        is_feed() ||
        empty( $content ) ||
        is_admin() ||
        ( function_exists( 'is_amp_endpoint' ) && is_amp_endpoint() ) ||
        method_exists( 'FLBuilderModel', 'is_builder_enabled' )
    ) {
        return $content;
    }
    

    It should contain also the ! \SiteGround_Optimizer\Helper\Helper::is_cron_disabled() check, so:

    
    if (
        is_feed() ||
        empty( $content ) ||
        is_admin() ||
        ( function_exists( 'is_amp_endpoint' ) && is_amp_endpoint() ) ||
        method_exists( 'FLBuilderModel', 'is_builder_enabled' ) ||
        ! \SiteGround_Optimizer\Helper\Helper::is_cron_disabled()
    ) {
        return $content;
    }
    

    You may suggest this to the developer.
    I hope it can solve your issue.

    So there’s no lazy load enabled on the site. I have no idea what else to do ūüôĀ

    This is a massive hit to our dynamic product ads…

    Is there anything else I can try??? Any other information I can give you that may help?

    All I can think of is I remember pressing the optimize all images one time in SG optimizer a while back.

    https://i.imgur.com/LRaN7uo.png

    • This reply was modified 1 month, 3 weeks ago by atrain009.
    • This reply was modified 1 month, 3 weeks ago by atrain009.
    Plugin Author Antonino Scarfì

    (@antoscarface)

    Hi,

    sorry for the delay on this response.

    You case is really strange, because you shouldn’t trigger that data:image instead of image link because of the option is disabled.

    I think of two possibilities:
    – you have some sort of caching. In this case, make sure every cache you have (from WordPress or from the hosting) are flushed;
    – you may have some other plugin that generated this issue. Please, try to deactivate all plugins and check the product catalog by refreshing it manually: if it will work without any problem, there is a plugin that created this issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.