WordPress.org

Support

Support » How-To and Troubleshooting » Image link doesn't set correctly … other posts/threads aren't helping

Image link doesn't set correctly … other posts/threads aren't helping

  • Using the Uploading/Insert Media button above the Visual editor, if I add an image into the page I’m unable to edit the link URL. When I go to the Edit Image popup and click Update it will save my change, but when I update the page it no longer reflects my URL, its reverted back to the default one.

    I’ve found a lot of other threads/posts/bug reports regarding this issue, but the fixes in those haven’t worked for me. I tried this patch/plugin:

    http://core.trac.wordpress.org/attachment/ticket/13429/save-custom-link-url.php

    which is linked to from the bug report page, but it still isn’t working for me. Any help would be greatly appreciated! Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

    esmi: I’ve done all of those things on 3.3.1 and it’s still happening to me.

    If I upload an image via the media uploader, then change the link, as soon as I save a draft, the image url reverts back to linking to the image.

    esmi

    @esmi

    Forum Moderator

    @jeff Clarke: It is considered impolite to interrupt another poster’s thread. Please post your own topic.

    @esmi Thanks for the quick reply! I will try all these things and post back the results. Stay tuned …

    This is happening to me as well. It seems to be a bug.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Image link doesn't set correctly … other posts/threads aren't helping’ is closed to new replies.
Skip to toolbar