WordPress.org

Support

Support » How-To and Troubleshooting » Image insertion causing post to go blank

Image insertion causing post to go blank

  • robinwyatt
    Member

    @robinwyatt

    Hi,

    This query relates to my post at http://www.robinwyatt.org/photography/?p=2695. I have 21 images in this photo blog entry. When I try to add a 22nd (I have 24 in total), clicking ‘preview’ shows that the entire post has gone blank. I have tried with several images, all with the same dimensions (640 x 426 px), and they all result in the same thing happening. I have tried searching for the cause of this problem, but found nothing.

    Cheers!

    Robin

Viewing 15 replies - 1 through 15 (of 29 total)
  • lockettpots
    Member

    @lockettpots

    The link throws a 404 error

    robinwyatt
    Member

    @robinwyatt

    Oh, do I need to click ‘Publish’ first for you to see it? I didn’t want to do that yet, for various reasons.

    robinwyatt
    Member

    @robinwyatt

    It’s now published. Please see http://www.robinwyatt.org/photography/photo-essays/wadi-el-rayan-egypt/. You’ll see that the first 21 images are there, but I could not add the final three without the whole post going blank.

    robinwyatt
    Member

    @robinwyatt

    Hi all,

    The same problem is still persisting with my post at http://www.robinwyatt.org/photography/photo-essays/wadi-el-rayan-egypt/. I have added the code ini_set(‘PCRE.BACKTRACK_LIMIT’, ‘1000000’); in wp-config.php as per what people have said at http://wordpress.org/support/topic/bug-wordpress-page-goes-blank-if-more-than-20-captions but that does not do anything.

    I made do with 21 images with captions after nobody replied to this thread during April. However, I changed something on the post today, and the problem returned. I then removed the 21st image, and the content returned. But I want to add that image back (and the other three mentioned earlier), and in future I want to be able to post photo essays with over 20 / 21 images. I’m a photographer… being limited like this is a real handicap.

    Hoping very much that someone can help!

    Robin

    esmi
    Forum Moderator

    @esmi

    This could well be a server issue. Have you spoken to your hosts about it?

    robinwyatt
    Member

    @robinwyatt

    Ok, I’ll try that and report back… .

    Is what it says at the link I gave above irrelevant in my case, or SHOULD it have fixed it?

    robinwyatt
    Member

    @robinwyatt

    According to online chat support, it’s unlikely to be to do with them. Nevertheless, I’ve submitted a request for them to take a close look. In the meantime, I’d be keen to know if anyone has any other ideas.

    robinwyatt
    Member

    @robinwyatt

    I heard back from my hosts. They did an investigation. Nothing wrong from their side. Please please can anyone suggest something from the WP side? I’m leaving the blank post up there so people can see so as to hopefully resolve this, but it looks quite unprofessional so I’m keen to find the answer soon 🙂

    robinwyatt
    Member

    @robinwyatt

    Please… anyone at all??

    robinwyatt
    Member

    @robinwyatt

    Bumping this… please, I can’t be the only one with this problem?! Every day I see people trying to access the photo essay I’ve deliberately left in the state it became when I tried to add a 21st image, so that some kind soul might see it and help out 🙂 The problem is, that post is making me look unprofessional :-s Adding ini_set(‘PCRE.BACKTRACK_LIMIT’, ‘1000000’); has not helped me. Pretty please, someone? 🙂

    esmi
    Forum Moderator

    @esmi

    I’m sorry but I think this is a server issue.

    robinwyatt
    Member

    @robinwyatt

    Esmi, both online support and the investigations team both confirmed that this is not a server issue. Online support told me he was absolutely certain there was no way it could be a server issue.

    esmi
    Forum Moderator

    @esmi

    WordPress does not limit the size of your posts nor how many images a post can contain. But your server can as part of its security configuration.

    robinwyatt
    Member

    @robinwyatt

    Even if WordPress is not deliberately limiting the number, there may be an error somewhere which is causing this. If you Google the problem, you’ll find many others have reported it (see the URL I posted above). It was an ongoing issue reported to WordPress some time back. Adding ini_set(‘PCRE.BACKTRACK_LIMIT’, ‘1000000’); seemed to help many people, but it has make no difference to me. I’ve already talked with my hosts about this twice. Their tech experts are SURE it’s nothing their side. Furthermore, they said that if they had installed any kind of limit like this, they know they would have had many people contacting them about it… which has not been the case.

    robinwyatt
    Member

    @robinwyatt

    I just contacted my hosts for a third time, as you keep referring me back to theme. The response:

    “As a precaution, I have disabled Suhosin under your account which is normally used to prevent common malicious attacks. Please let me know if this helps. Another thing to troubleshoot is your theme.”

    I refreshed the post in question with Suhosin disabled: no change. If it’s my theme (which was custom made), I’d love to know what I can do about this on my own. My developer has gone AWOL!

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Image insertion causing post to go blank’ is closed to new replies.