WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Image in profile its not showing

[Resolved] Image in profile its not showing

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author phpbits
    Participant

    @phpbits

    Hi ricardosantis,

    Congratulations for choosing this plugin and thanks a lot for using it. The plugin was tested using gravatar and working perfectly, if you can post the website link I’ll be very happy to check it. Thanks

    Cheers,
    phpbits

    ricardosantis
    Member

    @ricardosantis

    Hi,

    Thanks for response….

    My link is – http://www.institutoferrarezi.com/da-1a-a-3a-geracao-muito-alem-do-novo-codigo-da-pnl/

    Gravatar is OK, user is eugenio@institutoferrarezi.com

    I use plugin cache W3 TOTAL CACHE, is a problem ?

    Awaiting your response !

    Ricardo Santis

    Plugin Author phpbits
    Participant

    @phpbits

    Hi,

    Just checked your email and there is an avatar on it but not displaying on the author box. Did you clear the cache from total cache plugin? I’m not quite sure what’s the issue since I cannot get your wordpress login info because you are using the lite version. Thanks

    Cheers,
    phpbits

    sadtohappyproject
    Member

    @sadtohappyproject

    Hi @phpbits. Thankx for this plugin..I just installed it on my site Sad T0 Happy Project…but I am facing the same problem as #ricardosantis..where my image is not visible.

    Hey there!

    I’m having the same problem and the author has Gravatar on his email. No caching plugins used currently. Here is the site and article in guestion.

    Any help would be greatly appreciated! And darn this plugin looks awesome from the bat 🙂

    Cheers,
    NikoV

    Plugin Author phpbits
    Participant

    @phpbits

    Hi sadtohappyproject & NikoV,

    I’ve installed and used the gravatar and tests multiple times and I didn’t have any issues as long as the email was registered. Please check if this one works for you.

    Goto wp-author-box-lite/core/functions.display.php change line 184 to :

    $user_email = get_the_author_meta( 'user_email', $authorid );
    $avatar = get_avatar( $user_email , 80 );

    Let me know if this works. Thanks

    Cheers,
    phpbits

    Hey phpbits,

    Thanks for the code but that didn’t resolve the issue. The interesting thing is that while you are writing an article and use the “preview” button the gravatar is shown and working normally. But as you hit the publish button it vanishes.

    Any thoughts?
    NikoV

    Plugin Author phpbits
    Participant

    @phpbits

    Hi NikoV,

    I don’t actually have any idea with the problem because as long as the email is the same the wordpress will automatically grab the avatar. I’m just using the codex from wordpress to display it. Let me check if there is an option on gravatar.

    Cheers,
    phpbits

    Plugin Author phpbits
    Participant

    @phpbits

    Can you post the website link? The two links you’ve posted isn’t available. Thanks

    Cheers,
    phpbits

    I was having the same issue! So I went to COFIGURATIONS >> DISCUSSION and enabled the SHOW AVATAR. Works!

    Plugin Author phpbits
    Participant

    @phpbits

    Hi rclpaes,

    Thanks a lot for the solution :). Really appreciated. I hope it will work to others too.

    Cheers,
    phpbits

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Image in profile its not showing’ is closed to new replies.