Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Image for usage statistics needs styling and transparency

  • Just agreed to let YARPP track usage statistics in my WordPress site, and it appears to do that (at least in part) by adding a 1-pixel image to the page. This would be okay, except that I have default styles for images, one of which is a thick, black border. So the YARPP image shows up as a black square with a dot in the middle.

    I think you should add a style attribute to the YARPP image that sets the border to “none”. You may also want to set padding and margin to zero. Like so:

    style="border: none; padding: 0; margin: 0"

    You may also want to consider adding the following styles:

    • text-decoration: none
    • display: inline

    Finally, the image should be transparent. The 1-pixel image on my blog is a specific color, one that’s different than the background color. So I can see it, which is not really okay.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thanks for the tips. I will definitely consider adding some styling to make it more invisible. The gif that is served should be transparent, though… is it not transparent for you?

    It’s definitely not transparent. I did a “View Image” and got a single white(-ish) pixel in the center of a dark screen for this URL:

    http://yarpp.org/pixels/8cd919706aa0189a76d48c480a4083f9

    I zoomed in and the pixel is definitely there.

    What browser are you using to see it? I just ran some tests on it and verified that it is transparent.

    Is it possible that in your original site you’re seeing it just because, as you suggest, the text-decoration or border settings, etc?

    I’m using Firefox 19. And after doing some investigating, it does indeed appear that this is a FF bug/quirk. I made a simple web page that displays the 1-pixel image in the center of the screen, and it is indeed transparent, even in FF.

    But if I display the image by itself (enter http://yarpp.org/pixels/8cd919706aa0189a76d48c480a4083f9 in the FF address bar), it shows up as white on black. It only does this in FF — in Chromium the background is white.

    Not sure why it shows up on my blog the same way. That could be related to the automatic border.

    So I retract my transparency complaint.

    Thanks for checking. I’m on fx as well so I saw that too.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Image for usage statistics needs styling and transparency’ is closed to new replies.