• Resolved jvmedia

    (@jvmedia)


    Hi there,

    We program custom WordPress themes for our clients. As such, we heavily use Advanced Custom Fields to circumvent the default WordPress editor or blocks. On all of our sites, we have issues sharing links to Facebook in particular. With the example link, for instance, if you try to share that to facebook, it always shows the default image – no matter what setting we actually have in the admin. Right now, we have it set to “first image in content” and have actually removed the default image jpg … yet the default image is still what shows up. We’ve made sure to clear cache as well. We have tried each different setting with the same result. No matter what URL we try to share, Facebook only shows the default image.

    Twitter is very hit or miss. Sometimes it will show an actual image from the page, but most of the time it also shows the default image, no matter what the setting we select is.

    We’ve read through the documentation and that’s all pretty straight forward, but I have a feeling we’re either still doing something wrong, or this doesn’t work with content that is in Advanced Custom Fields or Woocommerce (as in the case of product images).

    I’m hoping to get to the bottom of it because it’s something that continually comes up for all of our clients who point out that every other website seems to be able to have the proper image from the page associated with the link they’re posting to social media.

    One other note – this isn’t something we noticed just with the latest version of the plugin. This happened with the older versions too.

    Thanks

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support wpsmort

    (@wpsmort)

    @jvmedia Your problem is caused by the fact that you have duplicate Open Graph meta tags. One set is coming from All in One SEO and there’s a second set coming from your theme or another plugin as seen here – https://a.supportally.com/cGQsU2

    You can’t have multiple sets of Open Graph tags as this will cause the types of problems you’re seeing.

    Thread Starter jvmedia

    (@jvmedia)

    Oh man … definitely a case of needing a second pair of eyes there, thanks! It does have to be coming from some other plugin as we don’t have any open graph meta tags in our theme file.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.