Support » Fixing WordPress » Image editor from visual editor not working

  • From the visual editor, when I click on an image I get the icons to edit or delete. Delete works. If I click “Edit Image” I get the Lightbox popup, a slight delay, then a “Not Found” page.

    I’ve compared the iframe to one on another blog that works. The broken one has this for the iframe address:
    http: //

    The working blog has this for the iframe address:
    http: //

    The only reference to ‘editimage.html’ appears in
    ‘wp-includes/js/tinymce/plugins/wpeditimage/editor_plugin.js’ and

    In both of those the link shows up as ‘editimage.html?ver=321&TB_iframe=true’
    You’ll see that the parameter ‘TB_iframe=true’ is missing from both the address of the iframe on both the working and the broken versions.

    I’ve tried modifying both of those files to see if I could change anything, and the address kept coming up the same. The files seem to be caching somewhere but I can’t find it. I’ve tried enabling, disabling and clearing SuperCache, and cleared browser cache.

    I’ve tried disabling all plugins. I’ve tried with multiple themes, including the one that works on another blog.

    I’m out of ideas. Anyone know where I should be looking?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I had the exact same problem. Tried debugging, etc. but no success. I even tried removing the wpeditimage folder and reinstalling WP from the update panel of the dashboard (which re-wrote the folder and files). No dice. The folder had always been there and the permissions were correct, so I doubted that was the issue. Thought it could be an .htaccess problem, but I couldn’t see what in there would be causing a problem.

    On a whim, I set my permalinks back to default (saved) and then back to my usual setting (saved). The image editor then resumed working.

    Hope this helps anyone else with this issue!

    I just had the same issue and it turns out this is an .htaccess issue, I had the exact same issue after adding two lined to my .htaccess, however it didn’t fix it when I removed the lines so I must have damaged something, restoreing in an old .htaccess file (I backed up) fixed the issue 🙂


    could you post that htaccess? or show the codes?

    I’m sorry to say I restored the backup copy of it without taking a copy, though to the naked eye I couldn’t see any differences, I can tell you it was after I added Bulletproof security (I think that was what damaged the .htaccess files).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image editor from visual editor not working’ is closed to new replies.