Support » Fixing WordPress » Image drag and drop problem with Firefox and TinyMCE on WP 2.0

  • Resolved guillep2k

    (@guillep2k)


    Hi. I’ve got a WordPress 2.0 blog in a path like http://www.domain.com/blog (i.e., not at the website’s document root but in a subdirectory). When I try to edit/create a post I can upload images alright, but when I try to drag and drop the image into the WYSIWYG editor, the picture is dropped without the ‘/blog/’ part. For example, my pictures are uploaded (using the WP upload feature) into $DOCUMENT_ROOT/blog/wp-content/uploads/my_picture.jpg. When checked via FTP, the picture looks fine in the right directory. I can browse and list and preview all the pictures I upload. However, when I drag the picture and drop it into the editor, a “broken link” picture is inserted. If I check the picture’s URL, it looks like http://www.domain.com/wp-content/etc. instead of http://www.domain.com/blog/wp-content/etc.
    This only shows up with Firefox (latest version and a very old one too), but in Internet Explorer it works perfectly fine, i.e., the drag and drop function inserts the image with the correct path.
    I checked up some stuff, and I could determine that the script inline-uploading.php is doing the things right (at least the generated content has the correct links). I could not determine where the /blog/ part of the path was lost, but I think it is somewhere into tiny_mce_gzip.php.

    Any comments would be appreciated.

    Guille

Viewing 7 replies - 1 through 7 (of 7 total)
  • Just for grins, suppose instead of drag and dropping the image, you clicked on it (left click) and chose “Send to Editor”? Is the link to the image still off when you do that?

    Hi, HandySolo. Thanks for answering. With “Send to Editor” it works fine in both navigators. Only the drag and drop function seems to fail with Firefox. (Oh, yeah, I could use “send to editor” instead, but it would be nice to have it working right, wouldn’t it?). 🙂

    Guille

    Yep, I can see it happening on my own install too now that I’ve tried.

    Interesting little bug. You might want to see if it is trac.wordpress.org and add it if necessary.

    OK, it is a bug, then. It seems that my password is not good for trac (at least yet; I registered just yesterday). I might try later.

    Guille

    I filed this in trac as ticket #2612:

    http://trac.wordpress.org/ticket/2612

    It worked for me after I removed the “document_base_url” line from wp-includes/js/tinymce/tiny_mce_gzip.php

    Martypauley’s suggestion absolutely fixes the problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Image drag and drop problem with Firefox and TinyMCE on WP 2.0’ is closed to new replies.