Support » Plugin: Simple Local Avatars » Image doesn’t show

  • Resolved overmyhead2

    (@overmyhead2)


    When I am in the User Editor, there is a new button “Choose from Media Library”. I can choose or upload an image OK, and then I get a second button “Delete local avatar”. But no image ever shows up anywhere and instead I just see the default profile picture.

    I have Ultimate Member installed, and Site health says everything is fine and up to date. (I don’t know how to upload a screen grab.) I tried chagning my upload directory from monthly to all in one place, but I still have the same problem.

    Thanks for any help!
    Robert

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Tung Du

    (@dinhtungdu)

    Hi @overmyhead2,

    What is the role of the account you used when trying to set the avatar? If you click the Save button, does the avatar show up after the page load? Does the avatar show if you use an administrator account?

    We have a similar issue reported [1] and a fix in the review queue [2] for it. Please let me know if it’s what happens to you!

    [1] https://github.com/10up/simple-local-avatars/issues/73
    [2] https://github.com/10up/simple-local-avatars/pull/74

    Thread Starter overmyhead2

    (@overmyhead2)

    Hi Tung,
    I was using the administrator account. If I click the save button nothing changes.
    But when I select an image, I get the additional button: “Delete local avatar”, so it looks like I was able to select an avatar.

    As a special note, I had problems with loading images into the media library. More than once the web host tech support fixed it. This is before I understood about cpanel. I haven’t had the media upload problem in a while, I only have the avatar not showing up problem, but I don’t know if the problems are related. I don’t know how my web host tech support fixed the image load problem last time. I think maybe it had something to do with gmagick. I’ve tried the avatar upload with both gmagick and imagick and same problem.

    Thank you for your help. Not sure how to upload a screenshot.

    Thank you,
    Andrew

    Plugin Support Tung Du

    (@dinhtungdu)

    @overmyhead2,

    To share screenshots, you can use https://cloudup.com/.

    Because you’re using the admin account, so your problem is different from #73 I mentioned above. Can you please try deactivating Ultimate Member then try setting/uploading an avatar?

    Thread Starter overmyhead2

    (@overmyhead2)

    Hi Tung,
    When I deactivated Ultimate Member, things worked considerably better. The profile picture shows up in some places, but not others (there’s a little blue-green square in the corner some places where there should be the profile picture.) It looks like not all sizes of the image are available to show. When I upload a larger picture it shows up in more but not all places.

    Thank you,
    Andrew

    Plugin Support Tung Du

    (@dinhtungdu)

    Hi @overmyhead2,

    Can you clarify where the avatar doesn’t show up?

    From my test, Ultimate Member supports uploading avatar out of the box, so that’s why it conflicts with SLA. If you need UM features, then you can use its local avatar feature without install SLA.

    Thread Starter overmyhead2

    (@overmyhead2)

    Hi Tung,
    The Avatar didn’t show up in most places I checked, but a tiny one showed up next to comments made by that person. So when I had UM installed without SLA, I couldn’t find a button or link to upload the image. I’ll check in with UM. Thanks for all your help and I’ll forward any useful info I get from the makers of UM.

    Andrew

    Thread Starter overmyhead2

    (@overmyhead2)

    Hi Tung,
    I feel like such a dunce! There was a setting in Ultimate Member to disable upload of profile photos, and that by default is set to Yes. So it is working now. Thank you for your gracious help and your work in supporting the WordPress platform.

    Andrew

    Plugin Support Tung Du

    (@dinhtungdu)

    @overmyhead2 Glad to know you solved your issue! I’ve just recorded a gif to show the avatar uploading in UM: https://media4.giphy.com/media/Ap40mPpdsOJbdpMGFX/giphy.gif?cid=790b7611ac2fbfca131e9339cac83c9b4ff7a6948513eeff&rid=giphy.gif&ct=g

    Thread Starter overmyhead2

    (@overmyhead2)

    Beautiful GIF!

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.