Image Directory Problem Uploading (5 posts)

  1. Xlyder
    Posted 9 years ago #

    I am new to wordpress, the first time it worked fine, but the day after I had installed wp my server was moved and the nightmare began.

    1. I couldn't upload images: I got a message saying that the directory home/site/blog/wp-content/2006/03 was not writable.

    solution: I manually created 2006/03

    2. Now I can upload images but get no automatic thumbnails with them as before.

    I've installed 2 brand new blog in different directories of my web site, with their own mysql database, one using cpanel fantastico. I run into the same first problem.

    I finally installed a clean(brand new) wp in one of my friends web sites, different host, and I still run into the same thing.

  2. abhideydas
    Posted 9 years ago #

    may be you should try making your directories writable by CHMOD'ing them to 777. load a FTP program, right click on that directory, choose the CHMOD option and change the permissions.

  3. Xlyder
    Posted 9 years ago #

    Thank you abhideydas, i've checked the folders. they all have writable permission and the unix 777

    I don't understand why I am having this, but is really discouraging? I'm considering creating my Mac into a server of its own and see if this is happening.

    It worked fine the first time, i was really proud and worked hard on building it up, only lasted 24hours.

  4. abhideydas
    Posted 9 years ago #

    don't get discouraged, we are here to help. in some servers directories created within a writable directory may not be writable by default. if its not too much of a trouble disable 'Organize my uploads into month- and year-based folders' in the Options>Miscellaneous Page and make the permission of the directory in which you want to upload 777.

    about the creation of the thumbnail, the name of the thumbnailed image is usually thumb-image.jpg where the name of the original image is image.jpg. please check whether you are accessing this image or not for some strange reason, WP dosen't do it automatically.

  5. Xlyder
    Posted 9 years ago #

    The miscellaneous page is on a directory with 777 permission. i also have disable the organize uploads feature.

    the first time i installed WP it did create the image_thumnail.jpg for the image.jpg i uploaded. It did this automatically. It was convenient.

    Now 3 servers, and 3 brand new installations it doesn't work.

    You can check out my art section and you can see my problem. it just eats bandwith. http://riodesign.net/blog/art/

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.