WordPress.org

Forums

Image Directory - problem (5 posts)

  1. ELFCO1
    Member
    Posted 2 years ago #

    Unable to create directory /home/elfcojoe/public_html/wp/wp-content/uploads/2013/01. Is its parent directory writable by the server?

    Website is http://www.elfco.coop/wp

    Cpanel is now 777
    I unchecked the sort by month/date - lost all my old images & still can't upload.

    I know enough to make me dangerous and could just cry. Thanks
    Aim

  2. Not sure what you mean by "Cpanel is now 777"

    You need to change the permissions of the uploads folder. You should be able to do this via FTP. Here's some info about that - http://codex.wordpress.org/Changing_File_Permissions

    You may also want to ask your hosting provider. They might be able to help and change the settings for you.

  3. ELFCO1
    Member
    Posted 2 years ago #

    All the permissions have been changed to writable. It still does not work. I'm not sure what else to do. I did contact our host person and have not heard anything back from them yet.

    Thanks for your suggestion.

  4. SuzanneL
    Member
    Posted 2 years ago #

    Thank you, but just changing files permissions does not work for me either. I have been running this WordPress site of mine for several years, and since I upgraded it to 3.5, it will not take media uploads. Other WordPress sites I am running on the same host in the same hosting account that I have not upgraded are still able to upload media, so I DARE NOT upgrade them.

    This is a new bug introduced into WordPress 3.5.x, and it is about time somebody started calling it that.

  5. sdls
    Member
    Posted 2 years ago #

    Experienced the same problem on several old sites. This problem occurs sporadically and is not commonly occuring on other websites on the same server

    Try going to your "Media Settings" page... do you see a "Store uploads in this folder" option with a long path to your uploads folder? If so... this is your problem... WordPress 3.5+ does not seem to require this long path, but more of a site relative path (which is great!)

    Change your "Store uploads in this folder" to "wp-content/uploads"... when you "save settings" you should see that field disapear entirely, never to bother us again ;-)

    This occured for me when my hosting provider changed the folder structure on the server making this long URL incorrect. Therefore WordPress could not find the "uploads" directory at all.

    Hope that helps...

    Here's some things you might want to check in case your still having problems...

    Update to WordPress 3.5 +
    Update all plugins
    Check file permissions 755 on the uploads dir/
    Check PHP version

Topic Closed

This topic has been closed to new replies.

About this Topic