Support » Fixing WordPress » Image crop area preview. Requires mouse interaction

  • This is a new install on a local instance of IIS. In ANY theme, including built-in default themes, if I go to Themes>>Customize>>Site Identity>>Select Logo and choose the logo, after choosing Select, I get an empty page that says:

    Crop Image
    ____
    Image crop area preview. Requires mouse interaction.

    Select is deactivated because it is waiting for me to crop the image. This page is blank. There is no image crop area preview. You basically have NO WAY to move forward. I’ve read this might be permission related. I have given USERS Full control. I have given IUSR Full control and I have given IUSR_Machine Full control to every folder under the root. It doesn’t seem to make any difference what the permissions are.

    I’ve never seen this before. Anyone have any other ideas to try something?

Viewing 4 replies - 1 through 4 (of 4 total)
  • I figured this out on my own. The answer for me was here–> https://stackoverflow.com/questions/24043991/image-crop-editor-not-working

    This solution worked for me:
    None of the above worked for me. So in an effort to give back after taking so much from stackoverflow, here is what I did.

    Sometime during the install process a URL rewrite rule was created in IIS. I disabled this rule and then the image crop worked!

    I just disabled the URLRewrite that was installed for WordPress.

    • This reply was modified 2 years, 11 months ago by sgifs.

    Thanks so much! I was going mad with this problem

    gch1985

    (@georginaholt)

    Having the same problem!
    Where exactly did you find this rewrite rule?
    Thanks!

    • This reply was modified 2 years, 7 months ago by gch1985.

    I was not able to crop images, too. The area where the cropping should show was just blank, instead I got the error message: “Image crop area preview. Requires mouse interaction.”

    This was on a freshly installed WordPress on a shared hosting provider. I also was at the theme image selector, as this was the first thing to touch.

    Now there was also other suspicous things:

    • the media image library showed no thumbnails.
    • When activating developer mode in the browser, I noticed some resources of WordPress could not load.

    Solution: the access rights to /wp-content were broken, Apache was no longer able to read the files that wordpress had written. In my case, recursively changing the access rights of wp-content to rwxr-x— did solve it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Image crop area preview. Requires mouse interaction’ is closed to new replies.