Support » Everything else WordPress » Image caption not synchronized to pages

  • Hello,

    When inserting an image from the media library into a page, the caption and alternative text are inserted as static HTML. So, if I update the caption in the media library, and the image is used in 100 pages, I have to find those pages (not sure how) and update the caption manually.

    I use the Kadence theme but I don’t think it’s theme or block specific( I tried the default WordPress image block as well as the Kadence Advanced Gallery). It seems default behavior to insert static HTML. How do big websites deal with image management?

    It there a plugin or any other way to keep the images in pages synchronized to the caption and alternative text in the media library?

Viewing 5 replies - 1 through 5 (of 5 total)
  • You can Investigate this issue with active the default WordPress theme. and check and you can disable the theme-related plugin as well to check which causes this.

    I want to say that is a picture caption make the specific fonts style or work all types of the fonts style I want to select designing from Anchor Fonts website

    Thread Starter pete3

    (@pete3)

    @ataurr Yes, but this is not a bug, it’s default behavior regardless of the theme I believe. I think that most WordPress users simply accept that captions are static and may be outdated over time. I don’t want that though.

    You said alternative text is inserted as static HTML. The caption is ok but alt text should be in the image alt tag. It should not be displayed in front.

    Maybe I am missing something?

    Thread Starter pete3

    (@pete3)

    @ataurr No, that’s not the issue. Let me give you an example. Let’s say I add an image of a bird in the sun to the Media Library, and I write “bird in the sun” in the alt and caption.

    A year later I have inserted this image in 100 pages. I now have a better picture of a bird, but it’s in a cage. I go into the Media Library and use a plugin like https://wordpress.org/plugins/enable-media-replace/ and replace the image in the media library, and I update the alt and caption to “bird in cage”.

    Those 100 pages now have an updated image but with the old, incorrect, alt and caption.

    This also happens if I don’t replace the image but simply decide there is a better alt and caption for that image. I can update it in the Media Library, but it won’t be updated on the pages where the image is already used.

    I find this an issue for bigger websites, but it seems to be the default way WordPress works, and I haven’t found any alternative yet.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Image caption not synchronized to pages’ is closed to new replies.