Support » Plugin: Gallery » Image caption

  • Resolved klassanov

    (@klassanov)


    Hello,
    the plugin works perfectly except this small problem.

    I noticed that the displayed image caption is not exactly the same as the original image caption. The difference is that in the displayed image caption every new word begins with a capital letter, but this is not what I need, I prefer having my original caption displayed. I noticed as well that if I have more capital letters in my original caption, for ex “XVI”, it is displayed as “Xvi”.

    Can you fix it please?
    Thanks in advance

    https://wordpress.org/plugins/gallery-lightbox-slider/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,
    I reported same issue under another post more than week ago. My post was there for more than week. I found this your post yesterday so I made comment where I wrote that is better to write same issues in same place. And today – both my posts are gone. I think somebody is playing with us ]:)

    In my first post I also wrote that it’s not only every first letter in each word (after space), but also each letter next to the letter with accent (in my case in czech language).

    I also wrote that I thinking about “rewriting” content of image captions by CSS properties in theme (text-transform and :first-letter) but I do not consider it right solution because in source code is still wrong formated text. I think plugin developer should fix it in plugin source codes.

    I also thing that this post can be about same issue.

    Tomáš

    After last update (1.0.0.21) still no change 🙁

    I used these CSS styles for now:

    div.pbCaptionText div.title span {
    	text-transform: lowercase;
    	display: block;
    }
    
    div.pbCaptionText div.title span::first-letter {
    	text-transform: uppercase;
    }

    So caption is in “Normal representation” for now. But IT IS NOT A SOLLUTION, because if you will use it you can’t use capitals in caption. All characters are lowercased and only first letter is uppercased.

    Tomáš

    Plugin Author GhozyLab

    (@ghozylab)

    Dear All,

    Please follow this steps :

    1. Click link below and MAKE SURE to change YOUR-DOMAIN-NAME with your own domain name.

    http://YOUR-DOMAIN-NAME/wp-admin/plugin-editor.php?file=gallery-lightbox-slider%2Finc%2Ffunctions%2Fglg-functions.php&plugin=gallery-lightbox-slider%2Finc%2Ffunctions%2Fglg-functions.php

    2. Find code below :

    $altnew = $(this).attr('alt').toLowerCase().replace(/\b[a-z]/g, function(letter) {
    
    			    return letter.toUpperCase();
    
    			});

    3. And replace with this :

    $altnew = $(this).attr('alt').replace(/\b[a-z]/g, function(letter) {
    
    			    return letter.toUpperCase();
    
    			});

    4. Save and DONE.

    We hope this help 🙂

    UPDATE :

    This issue already fixed. See details here

    Hi GhozyLab,
    I updated to version 1.0.0.23 and checked code you mentioned. I found that your change is applied in this version but it still doesn’t work.

    I think you should use multibyte toUpperCase and toLowerCase to make it work.

    You can see issue on my client’s page

    If you open any photo at bottom of page (photos with captions) and check source code for captions in lightbox you should see what your plugin does with caption text.

    I also really think that there should be option to disable this feature in plugin options because not always is goal to have fancy captions based on the good faith of the author that it will be nicer this way. Especially in case you need to have captions with specific shortcuts and names where you need specify which letter should be large and which should not. As was mentioned in berginformatik post.

    Tomáš

    Plugin Author GhozyLab

    (@ghozylab)

    Dear All,

    We already add new option to disable/enable Fancy Title in version 1.0.0.25

    Enjoy 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Image caption’ is closed to new replies.