Support » How-To and Troubleshooting » Image button in post not working

Image button in post not working

  • Hi!

    I’m having a rather strange problem.

    When I open a “new post” I can not click any of the media buttons.
    If i try creating a “new page” it all works fine.

    After clicking around a lot I figured out if I pushed just below the media buttons my browser opens the upload dialog box, not in a pop-up as usual, but on the entire screen as a seperate window. If i try upload an image I can’t ad it to the post cause the only way to get back to the post from here is to push the backward button or go to the dashboard. In both ways my changes are discareded.

    Any suggestions?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Link?


    Might be me beeing stupid now, but how can I link? This problem is inside my dashboard, “create new post”, section…

    Ah! Apologies. I’d not picked up you were talking about in the dashboard.



    I have got the same problem. I need to use the basic uploader and since the upgrade to 3.2.1. the button often is obscured by a white box. I can see the box if I resize the browser window.

    I’ve uploaded two screengrabs to Flickr:

    WordPress 3.2.1 upload button problem

    Thanks for suggestions. Here is a screenshot. The problem is that nothing happens when i push the media buttons on the top there. So I can’t even make a choice between the basic or flash uploader…

    Here’s the screenshot!

    Any progress? I have the same problem, plus I cannot insert liks either.

    When I try to insert a link it asks if I want to exit the page, cannot return to the post where the link should be inserted.

    Every once in a while it works…

    No… I have no clue how to fix this, so I haven’t been able to post new stuff to my page in quite some time. I’m on the verge to hire a professional to fix it.

    Disclaimer… I’m absolutely no expert on matters related to the Dashboard.

    I’ve sometimes had problems with the editor, though, so here are a couple of things to think about that have on occasion helped me:

    • Upload a new copy of the TinyMCE editor
    • Disable plugins one-by-one and retest after each disablement. If that doesn’t work, do the reverse (disable them all and re-enable them one-by-one).
    • Try a number of different browsers. I’ve sometimes found that these types of problems are browser-specific

    I have to say that I regard all of these as being long shots, but I just thought someone should say something.



    Where can I get a new copy of the TinyMCE editor? And where in the folders should I upload it?

    Re-upload the wp-admin and wp-includes folders from a fresh download of WordPress using FTP or use whatever file management application your host provides.

    I solved it: was a conflicting plugin (calendar posts). Apparently quite a lot of plug-ins can produce this error, I´d recommend checkeing these first.

    Make sure if you do want to reupload directories, grab a backup (just copy paste the directories you’re replacing to another location). You don’t want conflicting files from different versions.

    When I deactive a plug-in. Won’t I loose all the settings I’ve made for this plug-in? So if I’ve used quite some time to adjust the settings of a plug-in and deactivate it, do I have to all the settings all over again when I again activate it?

    Won’t I loose all the settings I’ve made for this plug-in?

    Highly unlikely. Most plugin settings are retained in the database unless the plugin is actually deleted (and even then, some poorly coded plugins don’ clear their settings out). If in doubt, take a screenshot of the plugin’s settings page before deactivating it.

    I’ve now tried deactive all the plug-ins. No luck. I also tried re-uploading the admin and includes folder from a fresh download of wordpress. Still no fix :/

    The strange thing is that the buttons work fine when creating a page. It’s only on new post they don’t work…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Image button in post not working’ is closed to new replies.