Support » Theme: OceanWP » Image attributes not showing on source code

  • Hi,

    I added alt text to all images in my page but still, Yoast SEO gives me the following message:

    “Image alt attributes: No images appear on this page. Add some!”

    Also, if I browse the source code for the page, I can’t see the images anywhere. I see them on the page when I load it with the browser, so it looks like OceanWP doesn’t store the image attributes in the page itself, which I think is really bad for SEO.

    I researched over the Internet and apparently, it relates to OceanWP and not to Elementor neither WordPress.

    These are the filenames and Alt Texts for some of the images on the page:

    Image 1:
    woman-thinking-on-how-to-overcome-depression-1.jpg  (Filename)
    woman thinking on how to overcome depression 1 (Title, Alt text, Caption, and Description)

    Image 2:
    a-woman-trying-to-overcome-depression-by-playing-guitar-on-a-bridge-1.jpg  (Filename)
    a woman trying to overcome depression by playing guitar on a bridge 1 (Title, Alt text, Caption, and Description)

    There are more images on the page, but I just wanted to illustrate my problem.

    I am working really hard on the SEO, please help me to solve this. 

    Best Regards,

    Ivan Gil

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hello,

    Try to switch the theme temporarily to default wordpress theme twenty nineteen and check it works there or not. In my opinion, it is not a theme related issue but I’m not sure. Please try to switch theme and check it happens with other themes or not.

Viewing 1 replies (of 1 total)
  • The topic ‘Image attributes not showing on source code’ is closed to new replies.