Support » Plugin: Yoast SEO » Image Attachment Links broken in 8.1.1

  • Resolved fob

    (@fob)


    No matter what you choose in settings (show or hide) attachment links do not work anymore. Verified this on a local system. Upgrading to the latest version redirects all images from the attachment (page) link to a normal image link.

    Deactivating the plugin brings attachment pages back on both (PHP 7.x) systems.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I do not think this is a bug, but the effect of a new feature.

    See https://wordpress.org/support/topic/redirect-image-attachment-urls-feature-missing/”

    No. That one is a big bug.

    The button says (translated): “Want to redirect attachment urls to your attachment file?” That definitely must be the default setting but now it changes the WordPress default to a nonsense-feature that can not be repaired without removing the plugin.

    Thankfully I remembered where I have to search for problems like this first. Others may only wonder what the hell is going on that removes their attachment pages. “Did WordPress remove the feature or is it a Core bug?” No it is not…

    I seem to be able to turn off this feature in 8.1.2. (Looks like having 301 browser caching issues left, from earlier tests on earlier tested images.)

    If I do so I can make use of attachment pages as usual (get back and use WordPress standard behaviour).

    So instead of simply saying “yes” (use attachments) I now have to choose the following settings to bring back attachments and stop unwanted redirects:

    “Anhangs-URLs auf die Anhangs-Datei weiterleiten? NO”
    (IGNORE THE TEXT, ITS NONSENSE – just say NO.)

    “By enabling this option, attachment URLs become visible to both your visitors and Google. To add value to your website, they should contain useful information, or they might have a negative impact on your ranking. Please carefully consider this and read this post if you want more information about the impact of showing media in search results.” (IGNORE THIS TEXT, IT`S NONSENSE.)

    “Zeige Medien in den Suchergebnissen? YES” (Allow indexing.)

    “Datum in der Snippet-Vorschau Ausblenden”
    (Turn off the date in snippets, if you like.)

    “Yoast SEO Meta-Box Zeigen”? YES (Show the meta box).

    – Looks like having heavy translation issues here (for German versions).
    – Select button seems to work again (with 8.1.2).

    Hopefully users will recognize that their attachment pages are gone with one of the updates so that they have to reconfigure things like explained avove to get them back.

    • This reply was modified 1 year, 4 months ago by .
    • This reply was modified 1 year, 4 months ago by .
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Image Attachment Links broken in 8.1.1’ is closed to new replies.