• Resolved marcorroma

    (@marcorroma)


    Hi, I have installed your plugin to remove exif data from media. Fantastic plugin!

    I have only one problem:
    every day I publish an image similar to the previous day, it is a table with updated data on the covid.
    Your plugin tells me that the file already exists, which prevents it from loading on my site.
    How can I solve? Can I disable this feature?

    I have tried to disable every setting of your plugin, but I always get the same error.
    Only if I deactivate your plugin, I fix the problem.
    I await support.

    Thanks for your work

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor hemenderki

    (@hemenderki)

    Hello @marcorroma!

    Glad you are enjoying the plugin.

    Would it be a solution for you to change the name of the image?

    The default WordPress behavior if you deactivate Better Images is to add a number after the file name. For example file-1.jpg, file-2.jpg and so on.

    You could do that manually before uploading. Would that be a reasonable solution for you?

    Thread Starter marcorroma

    (@marcorroma)

    I upload this image every day. The image name contains today’s date only. Ex. 2903.jpg, 3003.jpg, 3103.jpg, etc.

    How can I upload a media with a different name every day?

    However, it seems to me an ineffective way to say that the image already exists, just because it has a similar name to another image.

    One could tell if one media is the same as another only if they have the same name and the same size. What do you think about it?

    Plugin Contributor hemenderki

    (@hemenderki)

    This seems strange. If you upload images with different names you shouldn’t get any error message.

    Better Images works the same way as operating systems work. If you try to move a file to a folder where there is a file with the same name you will get an error message.

    It seems though that theres something else going one. I wont rule out that this could be a bug. Could you please write down all the setting you are using (or take a screenshot on the settings panel) so that we could try to replicate the issue.

    Thanx for your patient and help.

    Thread Starter marcorroma

    (@marcorroma)

    Hi, right now I have a similar problem.
    I’m uploading an image (just created by me with photoshop, it’s a banner) and it tells me that the file already exists.
    The file is called “desktop.jpg”
    I searched the media library for “desktop.jpg” and there is a file called san-desktop.jpg
    Screenshot:
    https://i.ibb.co/0DPpN0J/bug.png

    These files are totally different images, even the weight is different.
    Here are the two files here:
    https://gofile.io/d/Xbv9pX

    I await support. Thanks

    Update: If I change the name of the file, from desktop.jpg to gam-desktop.jpg, the problem is solved.

    • This reply was modified 1 month, 2 weeks ago by marcorroma.
    Plugin Contributor hemenderki

    (@hemenderki)

    Many thanks. That could very well be the bug right there. Let me look into it and get back to you.

    Thread Starter marcorroma

    (@marcorroma)

    Thank you!!

    Plugin Contributor hemenderki

    (@hemenderki)

    Hello @marcorroma!

    Just wanted to let you know that we managed to identify the bug and solve it. Please update the plugin to the latest version and it should work for you. Thank you again for taking the time to let us know about this bug!

    I will mark this thread as resolved, but don’t hesitate to get back to s if you experience any more problems.

    Thread Starter marcorroma

    (@marcorroma)

    Hi, I have updated your plugin, and now it works fine.
    Thank you so much for your support!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.