Support » Fixing WordPress » I'm using custom post types, my post content won't display!

  • I am using the “Ultimate Post Type Manager” plugin for my custom post types at Everything appears to be normal, I can publish the posts, and I can see them once they are published.
    The post title is there, and the author data is there, but my post content doesn’t display.

    I understand programing but am not an expert, i tried modifying my theme functions.php file (I am using Thesis), but everything remains the same. I can see the post titles but still no content…….

    The only code that I have in my functions.php file about the custom post types is:

    add_filter( 'pre_get_posts', 'my_get_posts' );
    function my_get_posts( $query ) {
    	if ( is_home() && false == $query->query_vars['suppress_filters'] )
    		$query->set( 'post_type', array( 'post', 'album', 'members', 'quote', 'attachment' ) );
    	return $query;

    I use this code so that my custom post types appear on the home page of my website, and that works fine…
    Everything else is done by the plugin, and I really don’t know how to fix this. Does anyone know how to fix this, Please Help me!!!

  • The topic ‘I'm using custom post types, my post content won't display!’ is closed to new replies.