WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] I’m trying to create a background hover image for each unique nav link

[Resolved] I’m trying to create a background hover image for each unique nav link

  • I was wondering if someone could help me out here. I’m trying to put hover background images on some of my links. I got it working on my sidebar tags by using…

    .wp-tag-cloud a.tag-link-38:hover, .wp-tag-cloud a.tag-link-38:visited {
    		background: url(images/peace.gif) no-repeat right;}

    where 38 represents the unique tag.

    I also got it working on the nav current page by using…

    #page-nav li.current_page_item a:hover {
    	    display: block;
    		background: url(images/here.gif) no-repeat scroll center top;}

    But for the life of my I can’t get it to work on each individual nav link. What I want is to have a unique background for each.

    the contact nav link is page-item-42 for which I tried…

    .page_item page-item-42:hover {
    	    display: block;
    		background: url(images/contact.gif) no-repeat scroll center top;
    }

    &

    .page_item page-item-42 a:hover {
    	    display: block;
    		background: url(images/contact.gif) no-repeat scroll center top;
    }

    &

    #page-nav li.page_item page-item-42 a:hover {
    	    display: block;
    		background: url(images/contact.gif) no-repeat scroll center top;
    }

    I would love some help on this one.

    My site is

    http://anonymouspond.com/

    Thanks!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] I’m trying to create a background hover image for each unique nav link’ is closed to new replies.
Skip to toolbar